
<!DOCTYPE html>
<html>
<!--[if IE 6]> <html class="ie6"> <![endif]-->
<!--[if IE 7]> <html class="ie7"> <![endif]-->
<!--[if IE 8]> <html class="ie8"> <![endif]-->
<!--[if IE 9]> <html class="ie9"> <![endif]-->

<head>
    <!-- Google Tag Manager -->
    <script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PV2DVS');</script>
    <!-- End Google Tag Manager -->
    <script type="text/javascript" src="/Scripts/mobile.min.js"></script>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0" />
        <meta name="application-name" content="AnandTech" />
    <meta name="google-site-verification" content="QejUZTJaqCr781DA0W_JNGjf4wS2xyffL3ohvIuRESc" />
    <meta property="article:publisher" content="https://www.facebook.com/AnandTech" />
    <link rel="shortcut icon" href="/favicon.ico" />
    <link rel="apple-touch-icon" sizes="144x144" href="/content/images/podcast_a_huge.png" />
    <link rel="alternate" type="application/rss+xml" title="RSS Feed for AnandTech.com" href="/rss/" />

    <title>AMD Announces Ryzen 5000 C-Series For High-End Chromebooks</title>                                                                            
     <link href="/Content/atfonts.css" rel="stylesheet" type="text/css">
    

    <!--[if IE]><style type="text/css">.pie {behavior:url(/Content/PIE.htc);}</style><![endif]-->
    <link href="/Content/css?v=813oG_8nNyCZXz7kVAe5eS_3v4I3z_2YsaGf_j29ZEg1" rel="stylesheet"/>

<link href="/Content/resp?v=bLpsGHlbt2J0jFe7q4kOjMR6XTWKxEGuyW8fHKDd5HM1" rel="stylesheet"/>
    <!--[if lt IE 9]>
        <link type="text/css" href="/content/ie8.css" rel="stylesheet" />
        <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.6.2pre/html5shiv.js"></script>
    <![endif]-->
    <script src="/bundles/jquery?v=guGiAVIp0f1T2TxJO-1NYkUT4F2gOxZwD3D5fOxH8tI1"></script>

    <script src="/bundles/javascript?v=3zoMUnHQHQfKEAEU_MI-Vwh0i7NhmCdIOW4S7phdnJo1"></script>

    
    <script type='text/javascript' src="/Scripts/dynamic.js"></script>

    <script type="text/javascript">
        var tmntag = tmntag || {};
        tmntag.cmd = tmntag.cmd || [];
        (function() {
            var tmnhead = document.createElement('script');
            tmnhead.async = true;
            tmnhead.type = 'text/javascript';
            tmnhead.src = ('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(tmnhead, node);
        })();
        tmntag.cmd.push(function () {
            if (screenContext != 'mobile') {
                tmntag.placement('2002');
            } else {
                tmntag.placement('2012');
            }
                tmntag.target({ "ccat1": "cpus" });
            tmntag.target({ "ctype": "pipeline" });
                tmntag.target({ "kw": "cpus,acer,amd,hp,chromebook,ryzen-mobile,ryzen-c-series,ryzen-5000,zen3" });

            tmntag.start();
        });
    </script>

    
        <link rel="canonical" href="https://www.anandtech.com/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks" />
            <link rel="shortlink" href="https://www.anandtech.com/show/17373" />
        <meta property="og:title" content="AMD Announces Ryzen 5000 C-Series For High-End Chromebooks" />
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.anandtech.com/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks" />
    <meta property="og:image" content="https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20For%20Chromebooks_678x452.jpg" />
    <meta name="author" content="Gavin Bonshor" />
    <meta name="twitter:card" content="fail" />

    <script type="text/javascript">

        var loggedIn = false;
        var isRoot = false;
    </script>
    <script src="/bundles/comments?v=4dsDdpYDBE_hkYPqV3fRU23zZmeXjfy10FIyxvSlyEk1"></script>

    <script type="text/javascript">

        $(document).ready(function () {
            $('a.icAddComment').click(DoTopPost);

        });

    </script>


</head>
<body>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PV2DVS"height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <!-- Begin comScore Tag -->
    <script>
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6035753" });
        (function () {
            var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
    <noscript>
        <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035753&cv=2.0&cj=1" />
    </noscript>
    <!-- End comScore Tag -->
    <header class="header">
        <div class="header_top">
            <div class="header_ad" id="header_ad">
                <script type="text/javascript">
                    if (screenContext != 'mobile') {
                      tmntag.cmd.push(function () { tmntag.adTag('header_ad', false); });
                    }
                </script>
            </div>
            <div class="logo">
                <a href="/">
                    <img src="/Content/images/logo2.png" alt="" />
                </a>
            </div>
            <div class="header_top_right">
                <div class="search_area">
                    <form action="/SearchResults" method="get">
                        <div class="search">
                            <input name="q" type="text" class="search_field">
                            <input name="" type="submit" class="search_btn" value="search">
                            <div class="clear"></div>
                        </div>
                        <div class="login">
                                <span id="loginHeader" style="display: none;">
                                    Welcome <a href="/Account/Details"><b><span id="loginUser"></span></b></a>
                                    <a href="/Account/Logout?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Log out</a>
                                </span>
                                <span id="logoutHeader">
                                    <a id="loginTop" href="/Account/Login?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Login</a>
                                    <a href="/Account/Register?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Register</a>
                                </span>
                        </div>
                        <div class="clear"></div>
                    </form>
                </div>

                    <div class="header_right_btm">
                        <span>
                            <a href="http://www.twitter.com/AnandTech">
                                <img src="/Content/images/icon-twitter.png" alt="" />
                            </a>
                            <a href="http://www.facebook.com/AnandTech/">
                                <img src="/Content/images/icon-facebook.png" alt="" />
                            </a>
                            <a href="/rss/">
                                <img src="/Content/images/icon-rss.png" alt="" />
                            </a>
                        </span>

                        <ul>
                            <li><a href="/home/about/">ABOUT</a></li>
                            <li><a href="/bench/">BENCH</a></li>
                            <li><a href="http://forums.anandtech.com">FORUMS</a></li>
                            <li><a href="/tag/podcast">PODCAST</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
            </div>
            <div class=" clrflt"></div>
        </div>

        <div class="header_top_resp">
            <div class="logo_resp">
                <a href="/"><img src="/Content/images/logo_resp.png" alt="" /></a>

            </div>
            
            <div class="header_top_resp_right">

                <a class="search_icon" href="#"></a>
                <div class="drop_down_search">
                    <span class="blk"></span>
                    <form action="/SearchResults" method="get">
                        <div class="search">
                            <input name="q" type="text" class="search_field">
                            <input name="" type="submit" class="search_btn" value="search">
                            <div class="clear"></div>
                        </div>
                    </form>
                </div>
                <a class="home" href="#"></a>
                <div class="drop_down_home ">
                    <span class="blk"></span>
                    <a href="/home/about/">ABOUT</a>
                    <a href="/bench/">BENCH</a>
                    <a href="http://forums.anandtech.com">FORUMS</a>
                    <a href="/tag/podcast">PODCAST</a>
                    <a id="loginTopMobile" href="/Account/Login">LOGIN</a>
                    <a href="/Account/Register">REGISTER</a>
                </div>
                <a class="nav_icon show_resp2" href="#"></a>
                <div class="drop_down_nav">
                    <span class="blk"></span>
                    <div class="navmobile ignoreclick"><a href="#">PC Components<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/ssd">SSDs</a></li>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSUs</a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                            <li><a href="/tag/nas">NAS</a></li>
                            <li><a href="/tag/storage">Storage</a></li>
                        </ul>
                    </div>
                    <div class="navmobile ignoreclick"><a href="#">Smartphones &amp; tablets<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/smartphones">Smartphones</a></li>
                            <li><a href="/tag/tablets">Tablets</a></li>
                            <li><a href="/tag/huawei">Huawei</a></li>
                            <li><a href="/tag/htc">HTC</a></li>
                            <li><a href="/tag/samsung">Samsung</a></li>
                            <li><a href="/tag/google">Google/Android</a></li>
                            <li><a href="/tag/microsoft">Microsoft</a></li>
                            <li><a href="/tag/apple">Apple</a></li>
                            <li><a href="/tag/soc">SoCs</a></li>
                        </ul>
                    </div>
                    <div class="navmobile ignoreclick"><a href="#">Systems<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/laptops">Notebook Reviews</a></li>
                            <li><a href="/tag/desktops">Desktop Reviews</a></li>
                            <li><a href="/tag/mac">Mac Reviews</a></li>
                            <li><a href="/tag/ultrabook">Ultrabooks</a></li>
                        </ul>
                    </div>
                    <div><a href="/tag/enterprise">ENTERPRISE & IT</a></div>
                    <div class="navmobile ignoreclick"><a href="#">GUIDES<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/show/9793/best-cpus">Best CPUs</a></li>
                            <li><a href="/show/9799/best-ssds">Best SSDs</a></li>
                            <li><a href="/show/9798/best-laptops">Best Laptops</a></li>
                            <li><a href="/show/9770/best-android-phones">Best Android Phones</a></li>
                            <li><a href="/show/12050/best-video-cards">Best Video Cards</a></li>
                            <li><a href="/show/12056/best-psus">Best PSUs</a></li>
                            <li><a href="/show/12072/best-motherboards">Best Motherboards</a></li>
                            <li><a href="/show/12058/best-gaming-laptops">Best Gaming Laptops</a></li>
                            <li style="height: 60px !important;"><a href="/show/12061/best-mechanical-keyboards">Best Mechanical Keyboards</a></li>
                            <li><a href="/show/12075/best-consumer-hdds">Best Consumer HDDs</a></li>
                        </ul>
                    </div>
                    <div><a href="/tag/deals">DEALS</a></div>
                </div>
            </div>
        </div>
        
    <nav class="breadcrumb nowidth show_resp2">
        <ul>
            <li>
                <a href="/">Home</a><span>&gt;</span>
                    <a href="/tag/cpus">CPUs</a>
            </li>
        </ul>
        <div class="clear"></div>
    </nav>


        
        <nav class="nav inner_nav animenu">
            <input type="checkbox" id="button">
            <label for="button">Menu</label>
            <ul>
                <li>
                    <a href="#" class="ignoreclick">PC Components<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/cpus">CPUs</a></li>
                        <li><a href="/tag/gpus">GPUs</a></li>
                        <li><a href="/tag/mb">Motherboards</a></li>
                        <li><a href="/tag/ssd">SSDs</a></li>
                        <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSUs</a></li>
                        <li><a href="/tag/memory">Memory</a></li>
                        <li><a href="/tag/nas">NAS</a></li>
                        <li><a href="/tag/storage">Storage</a></li>
                    </ul>

                </li>
                <li>
                    <a href="#" class="ignoreclick">Smartphones &amp; tablets<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/smartphones">Smartphones</a></li>
                        <li><a href="/tag/tablets">Tablets</a></li>
                        <li><a href="/tag/huawei">Huawei</a></li>
                        <li><a href="/tag/htc">HTC</a></li>
                        <li><a href="/tag/samsung">Samsung</a></li>
                        <li><a href="/tag/google">Google/Android</a></li>
                        <li><a href="/tag/microsoft">Microsoft</a></li>
                        <li><a href="/tag/apple">Apple</a></li>
                        <li><a href="/tag/soc">SoCs</a></li>
                    </ul>
                </li>
                <li>
                    <a href="#" class="ignoreclick">Systems<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/laptops">Notebook Reviews</a></li>
                        <li><a href="/tag/desktops">Desktop Reviews</a></li>
                        <li><a href="/tag/mac">Mac Reviews</a></li>
                        <li><a href="/tag/ultrabook">Ultrabooks</a></li>
                    </ul>
                </li>
                <li>
                    <a href="/tag/enterprise" class="">Enterprise & IT</a>
                </li>
                <li>
                    <a href="#" class="ignoreclick">Guides<span>▼</span></a>
                    <ul>
                        <li><a href="/show/9793/best-cpus">Best CPUs</a></li>
                        <li><a href="/show/9799/best-ssds">Best SSDs</a></li>
                        <li><a href="/show/9798/best-laptops">Best Laptops</a></li>
                        <li><a href="/show/9770/best-android-phones">Best Android Phones</a></li>
                        <li><a href="/show/12050/best-video-cards">Best Video Cards</a></li>
                        <li><a href="/show/12056/best-psus">Best PSUs</a></li>
                        <li><a href="/show/12072/best-motherboards">Best Motherboards</a></li>
                        <li><a href="/show/12058/best-gaming-laptops">Best Gaming Laptops</a></li>
                        <li style="height: 60px !important;"><a href="/show/12061/best-mechanical-keyboards">Best Mechanical Keyboards</a></li>
                        <li><a href="/show/12075/best-consumer-hdds">Best Consumer HDDs</a></li>
                    </ul>
                </li>
                <li>
                    <a href="/tag/deals" class="">Deals</a>
                </li>
            </ul>
        </nav>

            <nav class="topic_menu topic_inner" style="width: 280px; padding: 6px 0 0 6px;float: right;">
                <div class="fbholder-fp" style="float:left; margin-right: 15px;"><div class="fb-like" data-href="http://www.facebook.com/AnandTech" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-colorscheme="dark"></div></div>
                <a href="https://twitter.com/anandtech" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false"></a>
                <script>!function (d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (!d.getElementById(id)) { js = d.createElement(s); js.id = id; js.src = "//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); } }(document, "script", "twitter-wjs");</script>

            </nav>
            <nav class="topic_menu topic_inner">
                <ul>
                    
                    <li class="topin_title">TRENDING TOPICS</li>
                            <li class="nosep"><a href="/tag/intel">Intel</a></li>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/amd">AMD</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/storage">Storage</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                            <li><a href="/tag/asus">Asus</a></li>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSUs</a></li>
                </ul>
                <div class="clear"></div>
            </nav>
    </header>

    <section class="content">
            <section class="main_cont">

                

<div class="breadcrumb_area hide_resp2">
    <nav class="breadcrumb">
        <ul>
            <li><a href="/">Home</a><span>&gt;</span></li>
                <li><a href="/tag/cpus">CPUs</a></li>
        </ul>
        <div class="clear"></div>
    </nav>

    
    <div class="clear"></div>
</div>



<div class="review_blog">
    <div class="blog_top_left">
        <a href="/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks"><h1>AMD Announces Ryzen 5000 C-Series For High-End Chromebooks</h1></a>
        <span>by <a href="#"><a class='b' href='/Author/200'>Gavin Bonshor</a></a> <em>on May 5, 2022 4:30 PM EST</em> </span>
        <ul class="hide_resp2">
            <li>Posted in</li>
            <li><a href="/tag/cpus">CPUs</a></li>
                <li><a href="/tag/acer">Acer</a></li>
                <li><a href="/tag/amd">AMD</a></li>
                <li><a href="/tag/hp">HP</a></li>
                <li><a href="/tag/chromebook">Chromebook</a></li>
                <li><a href="/tag/ryzen-mobile">Ryzen Mobile</a></li>
                <li><a href="/tag/ryzen-c-series">Ryzen C-Series</a></li>
                <li><a href="/tag/ryzen-5000">Ryzen 5000</a></li>
                <li><a href="/tag/zen3">Zen3</a></li>
        </ul>
    </div>

    <div class="blog_top_right show_resp2">
        <span><a href="#comments">4 <small>Comments</small></a></span>
        | <strong><a class="icAddComment" href="/Comment/NewComment/17373?page=1&commentPage=1&showAllComments=False">Add A Comment</a></strong>
    </div>
    <div class="blog_top_right hide_resp2">

            <span><a href="#comments">4 <small>Comments</small></a></span>
        <strong><a class="icAddComment" href="/Comment/NewComment/17373?page=1&commentPage=1&showAllComments=False">+ Add A<br>Comment</a></strong>
    </div>
    <div class="clear"></div>
</div>


<div class="sidepadding review">

                <div style="margin: 0 auto; text-align: center;">
                    <img src="https://images.anandtech.com/doci/17373/AMD Ryzen 5000 C Series For Chromebooks_678x452.jpg" alt="" />
                </div>

            <div style="float: right; margin: 13px 0px 15px 15px;">
                <div id="middle_ad">
                    <script type="text/javascript">
                        if (screenContext != 'mobile') {
                            tmntag.cmd.push(function () { tmntag.adTag('middle_ad', false); });
                        }
                    </script>
                </div>

                <div class="clear"></div>



            </div>


        <div class="articleContent">
            <p>In September 2020, AMD released its Ryzen 3000 C-series for Chromebooks, a line up of budget-priced chips based on the 12nm Picasso (Ryzen+) architecture that featured up to 4 cores and 8 threads and up to 11 Radeon Vega compute units. Nearly two years on and AMD has just announced four new Ryzen 5000 C-series SKUs designed to bring the performance benefits of its Cezanne (Zen 3) architecture to the Chromebook space.</p>

<p>The four new Ryzen 5000 C-series processors range from 8C/16T to 2C/4T, all with a 15 W TDP and designed to improve productivity and battery life over existing Ryzen 3000 C-series processors and Intel&#39;s 11th Gen Tiger Lake chips.</p>

<p>Aimed at the premium area of the Chromebook market, the new AMD Ryzen 5000 C-series looks to offer OEMs and users premium options for the latest generation of Chromebooks with some higher-end features such as fast charging and Wi-Fi 6E networking capability.</p>

<table border="0" style="text-align: center;" width="95%">
	<tbody>
		<tr class="tgrey">
			<td colspan="9">AMD Ryzen 5000 C-Series For Chromebooks (Zen 3)</td>
		</tr>
		<tr class="tlblue">
			<td><i>AnandTech</i></td>
			<td colspan="2" rowspan="1">Core/<br />
			Thread</td>
			<td>Base<br />
			Freq</td>
			<td>1T<br />
			Freq</td>
			<td>L2/L3<br />
			Cache</td>
			<td>iGPU</td>
			<td>iGPU<br />
			Freq</td>
			<td>TDP</td>
		</tr>
		<tr>
			<td class="tlgrey"><b>Ryzen 7 5825C</b></td>
			<td>8</td>
			<td>16</td>
			<td>2000</td>
			<td>4500</td>
			<td>20 MB</td>
			<td>Vega 8</td>
			<td>Up to 1.8 GHz</td>
			<td>15 W</td>
		</tr>
		<tr>
			<td class="tlgrey"><b>Ryzen 5 5625C</b></td>
			<td>6</td>
			<td>12</td>
			<td>2300</td>
			<td>4300</td>
			<td>19 MB</td>
			<td>Vega 7</td>
			<td>Up to 1.6 GHz</td>
			<td>15 W</td>
		</tr>
		<tr>
			<td class="tlgrey">Ryzen 3 5425C</td>
			<td>4</td>
			<td>8</td>
			<td>2700</td>
			<td>4100</td>
			<td>10 MB</td>
			<td>Vega 6</td>
			<td>Up to 1.5 GHz</td>
			<td>15 W</td>
		</tr>
		<tr>
			<td class="tlgrey">Ryzen 3 5125C</td>
			<td>2</td>
			<td>4</td>
			<td>3000</td>
			<td>3000</td>
			<td>9 MB</td>
			<td>Vega 3</td>
			<td>Up to 1.2 GHz</td>
			<td>15 W</td>
		</tr>
	</tbody>
</table>

<p>Looking at the specifications of the Ryzen 5000 C-series line-up, the top model is the Ryzen 7 5825C with an impressive 8 cores and 16 threads which is double that of the previous top-tier Chromebook Ryzen processor, the AMD Ryzen 7 3700C. It has a base core frequency of 2 GHz, with a boost core clock of up to 4.5 GHz on a single core, which is bolstered by its Radeon Vega 8 integrated graphics with a maximum boost frequency of up to 1.8 GHz.</p>

<p>The second model in the new line-up is the Ryzen 5 5625C, which has 6 cores, 12 threads, and integrated Radeon Vega 7 graphics with a maximum boost frequency of up to 1.6 GHz. The 6 cores feature a base frequency of 2.3 GHz, while one of these cores can boost up to 4.3 GHz for applications that demand additional performance.</p>

<p align="center"><a href="https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20Slide%20Deck%201.JPG"><img alt="" src="https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20Slide%20Deck%201_575px.JPG" /></a></p>

<p>Focusing on the two entry-level models in the line-up, the Ryzen 3 5425C benefits from 4 cores and 8 threads with a base frequency of 2.7 GHz, with a boost frequency on one core of up to 4.1 GHz, as well as AMD&#39;s Radeon Vega 6 graphics that can boost up to 1.5 GHz. The Ryzen 3 5125C is the lowest in the new C-series stack with just 2 cores and 4 threads, has a consistent core clock speed of 3 GHz, and has 3 Vega graphics compute cores with a maximum boost frequency of up to 1.2 GHz.</p>

<p>As we go from top to bottom, each model in the line-up increases in base core frequency, while the boost clocks bar the Ryzen 3 5125C, which has a set core clock speed of 3 GHz, experience a drop in frequency. All the Ryzen 5000 C-series models feature a 15 W TDP envelope, so core frequency on both the Zen 3 cores and the Radeon Vega cores will depend on the application, task, or game being used to optimize the relative power envelope to fit within the 15 W TDP threshold.</p>

<p align="center"><a href="https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20Slide%20Deck%204.JPG"><img alt="" src="https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20Slide%20Deck%204_575px.JPG" /></a></p>

<p>While we don&#39;t typically concern ourselves with vendor-given performance data, perhaps the most impressive of AMD&#39;s claims is battery life. AMD is claiming that the Ryzen 5 5625C has up to improve battery life&nbsp;by 94% when directly compared to Intel&#39;s Core i5-1135G7 processor, which, if true, is very impressive. One of the main benefits of the Chromebook series is usability, and having an improved battery life can increase overall productivity and lifespan when using it while traveling between charges.</p>

<p>So far, AMD has announced two of its partners already on board with its Ryzen 5000 C-series for Chromebooks, including HP and Acer. Both are launching new models due later on in the year, but AMD highlighted two new models:</p>

<h3>HP Elite C645 G2 Chromebook</h3>

<p align="center"><a href="https://images.anandtech.com/doci/17373/tAHZKyXoHQaP3iWNAmv6DS-970-80.jpg.jpg"><img alt="" src="https://images.anandtech.com/doci/17373/tAHZKyXoHQaP3iWNAmv6DS-970-80.jpg_575px.jpg" /></a></p>

<p>The first of the new Chromebooks to feature AMD&#39;s Ryzen 7 5825C processor is the HP Elite C645 G2. HP is expected to offer multiple display options, including various configurations of its 14&quot; 1080p touchscreen panel and plenty of impressive features. These include support for up to 16 GB of LPDDR4X memory with up to 512 GB of PCIe storage. Other features include the latest Wi-Fi 6E wireless and BT 5.2 connectivity and an optional 4G LTE version. The HP Elite C645 will also have a 5 MP integrated webcam, a SmartCard terminal for a CAD-capable keyboard, and an SEC fingerprint sensor for added security.</p>

<p>The HP Elite C645 G2 Chromebook is expected to hit retail shelves in Q2 2022, with pricing currently unknown.</p>

<h3>Acer Chromebook Spin 514</h3>

<p align="center"><a href="https://images.anandtech.com/doci/17373/hsD3rHmP9MzcUQe4sS2nyL-970-80.png.jpg"><img alt="" src="https://images.anandtech.com/doci/17373/hsD3rHmP9MzcUQe4sS2nyL-970-80.png_575px.jpg" /></a></p>

<p>The second of the new Ryzen 5000 C-series Chromebooks is the Acer Chromebook Spin 514, which is a 2-in-1 convertible with a 14&quot; touchscreen. Acer is using the AMD Ryzen 7 5825C processor in this model, and it can support up to 256 GB of PCIe Gen 3 storage and support the latest Wi-FI 6E routers with BT 5.2 connectivity. Acer has specified that the Chromebook Spin 514 includes military-grade MIL-STD 810 durability with a Corning gorilla glass touchscreen panel that supports sRGB 100% color.</p>

<p>At the time of writing, Acer says the Chromebook Spin 514 will be available in Q3 2022, with expected pricing not disclosed.</p>

<p>It is expected that more vendors will adopt AMD&#39;s Ryzen 5000 C-series processors for Chromebooks in the coming months, although these are OEM only, and pricing is currently unknown on each of the models.</p>

<p>Source: <a href="https://www.amd.com/en/processors/chrome-enterprise">AMD</a></p>

        </div>
        <div class="article_links">
            
        </div>
            <div class="clear"></div>
            <div class="fl-lt" style="clear: both; margin: 25px 0px 15px; height: 35px; width:150px;">
                <iframe src="//www.facebook.com/plugins/like.php?href=http://www.anandtech.com/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks&amp;width&amp;layout=button_count&amp;action=like&amp;show_faces=true&amp;share=true&amp;height=21&amp;appId=201944423199922" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:21px;" allowtransparency="true"></iframe>
            </div>
            <div class="fl-lt" style="margin: 25px 0px 15px; height: 35px; width:90px;">
                <div class="g-plusone" data-size="medium"></div>
                <script type="text/javascript">
                    (function () {
                        var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                        po.src = 'https://apis.google.com/js/platform.js';
                        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
                    })();
                </script>
            </div>
            <div class="fl-lt" style="margin: 25px 0px 15px; height: 35px; width:120px;">
                <a href="https://twitter.com/share" class="twitter-share-button" data-lang="en">Tweet</a>
                <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
            </div>
            <div class="fl-rt" style="margin: 22px 0px 15px;">
                <div class="button left"><a href="/print/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks" class="print_article"><span>PRINT THIS ARTICLE</span></a></div>
            </div>
            <div class="fl-rt" style="margin: 22px 8px 15px; height: 0px;">
            </div>
            <div class="clear"></div>
            <div style="text-align: center;" id="resp_middle_ad">
                <script type="text/javascript">
                    if (screenContext == 'mobile') {
                        tmntag.cmd.push(function () { tmntag.adTag('resp_middle_ad', false); });
                    }
                </script>
            </div>


</div>

    <div class="discussion" id="comments">
        
<script type="text/javascript">
    
    $(document).ready(function () {
        window.hasCommenting = true;        
        $('#icTopPost').click(DoTopPost);

        $("#icLoginLink").click(function (e) {
            window.gotoComment = true;

            $.fancybox.open([
                    {
                        href: '#inlineLogin'
                    }
                ], {
                    padding: 0,
                    titlePosition: 'inside',
                    transitionIn: 'none',
                    transitionOut: 'none',
                    afterShow: function (current, previous) {
                        $('#UserName').focus();

                    }
                });

            e.preventDefault();
            return false;

        });
        
        $("#inlineComment").click(function (e) {
            DoComment();
            e.preventDefault();
            return false;
        });

        $("div#comments a.jqc").click(function () {
            $.get(this.href, scrollComments);
            return false;
        });

    });
</script>
<div><a id="commentsAnchor"></a></div>
<ul id="icReplyHolder">
    <li id="replybox" class="blog_post_area" style="display: none;">
        <div class="blog_post_btm">
            <h3>Post Your Comment</h3>
            <span id="icMessage">
                    
                        Please <a id="icLoginLink" href="/Account/Login?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">log in</a> or <a href="/Account/Register?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">sign up</a> to comment. 
                    
                                                                                                                                                                                               
            </span>
            <textarea cols="10" rows="10" class="comment_txtarea" placeholder="Enter your comment" id="CommentInput" name="CommentInput"></textarea>
            <input name="" type="button" id="inlineComment" class="submit_comment_btn" value="Submit Comment" disabled="disabled">
            <img alt="" src="/Content/images/ajax-loader13.gif" id="icAjaxLoader"/>
            <input type="hidden" name="ParentCommentId" id="ParentCommentId" />
            <input type="hidden" name="ReplyLevel" id="ReplyLevel" />
            <input data-val="true" data-val-number="The field ContentId must be a number." data-val-required="The ContentId field is required." id="ContentId" name="ContentId" type="hidden" value="17373" />
            <div class="clear"></div>
        </div>
    </li>
</ul>

<div class="blog_comments">
    
    <a id="icTopPost" href="/Comment/NewComment/17373?page=1&commentPage=1&showAllComments=False" class="print_article top_post">POST A COMMENT</a>
    

    
        <h2>4 Comments</h2>
        <h3><a href="/comments/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks">View All Comments</a></h3>
    <ul id="ulComments">


<li id="cid771496" style="">
    <h4><a>nandnandnand</a> - Thursday, May 5, 2022 - <a href="/comments/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks/771496" style="font-weight:normal; color:#8E8C8C;">link</a></h4>
    <span>The 5125C is an 8-core Barcelo die cut down to 2 cores with turbo disabled. Waste of good silicon, although it will outperform older chips. It shows why you want quad-core dies like Van Gogh available for budget products, or the industry should just abandon the dual-core soon.</span>
    <a onclick="loadReplyBox(this,'771496','0','RE: ');return false;" href="/Comment/NewComment/17373?page=1&commentPage=1&parentCommentId=771496&showAllComments=False" class="reply_btn">Reply</a>
    <div class="clear"></div>
</li>



<li id="cid771497" style="">
    <h4><a>shabby</a> - Thursday, May 5, 2022 - <a href="/comments/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks/771497" style="font-weight:normal; color:#8E8C8C;">link</a></h4>
    <span>How do these differ from the non C chips? </span>
    <a onclick="loadReplyBox(this,'771497','0','RE: ');return false;" href="/Comment/NewComment/17373?page=1&commentPage=1&parentCommentId=771497&showAllComments=False" class="reply_btn">Reply</a>
    <div class="clear"></div>
</li>



<li id="cid771498" style="padding-left:18px;">
    <h4><a>nandnandnand</a> - Thursday, May 5, 2022 - <a href="/comments/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks/771498" style="font-weight:normal; color:#8E8C8C;">link</a></h4>
    <span>They appear identical to the other Barcelo chips according to Notebookcheck and AMD&#39;s website. Same clock speeds. The exception is the Ryzen 3 5125C, which is the first dual-core APU AMD has made using an 8-core die.</span>
    <a onclick="loadReplyBox(this,'771498','1','RE: ');return false;" href="/Comment/NewComment/17373?page=1&commentPage=1&parentCommentId=771498&showAllComments=False" class="reply_btn">Reply</a>
    <div class="clear"></div>
</li>



<li id="cid771499" style="">
    <h4><a>PeachNCream</a> - Thursday, May 5, 2022 - <a href="/comments/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks/771499" style="font-weight:normal; color:#8E8C8C;">link</a></h4>
    <span>I can think of no better use for these CPUs than being turned into instant ewaste data miners for good old disgusting Google&#39;s peepshow into its users&#39; lives. Keep up the good work OEMs and AMD!</span>
    <a onclick="loadReplyBox(this,'771499','0','RE: ');return false;" href="/Comment/NewComment/17373?page=1&commentPage=1&parentCommentId=771499&showAllComments=False" class="reply_btn">Reply</a>
    <div class="clear"></div>
</li>



    </ul>
</div>
    <nav class="page_nav">
        <ul>
                        
                <li>
                        <div  class="a"><label for="">1</label></div>
                </li>
                                </ul>
    </nav>

    </div>



            </section>


<aside class="sidebar">
    <div id="side_ad">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad', false); });
            }
        </script>
    </div>
    
        <article class="pipeline_stories">
            <div class="pipeline_title">
                <h2><a href="/pipeline">PIPELINE STORIES</a>
                </h2>
                <a href="mailto:tips@anandtech.com">+ Submit News</a>
                <div class="clrflt"></div>
            </div>

            <strong>
                <a href="/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks">AMD Announces Ryzen 5000 C-Series For High-End Chromebooks</a>
                <img src="/Content/images/dell_reveal_arrow.png" alt="">
            </strong>

            <span><a href="/show/17371/at-deals-razer-viper-ultimate-mouse-and-dock-only-80">AT Deals: Razer Viper Ultimate Hyperspeed Mouse and Dock Only $80 at Amazon</a></span>
            <span><a href="/show/17370/at-deals-msi-optix-ips-down-to-280-at-amazon">AT Deals: MSI Optix 25-Inch 240Hz IPS Down to $280 at Amazon</a></span>
                 
            <ul>
                    <li ><a href="/show/17369/qualcomm-launches-wifi-7-networking-pro-series-for-10gbps-access-points">Qualcomm Launches Wi-Fi 7 Networking Pro Series for 10Gbps Access Points</a></li>
                    <li ><a href="/show/17368/at-deals-viewsonic-omni-xg2705-monitor-now-190">AT Deals: ViewSonic Omni XG2705 27-Inch 144 Hz IPS Monitor Now $190</a></li>
                    <li ><a href="/show/17366/intel-meteor-lake-client-soc-up-and-running">Intel: Meteor Lake Chiplet SoC Up and Running</a></li>
                    <li ><a href="/show/17364/intel-reports-q1-2022-earnings-improved-enterprise-sales-buoy-weaker-client-revenue">Intel Reports Q1 2022 Earnings: Improved Enterprise Sales Buoy Weaker Client Revenue</a></li>
                    <li ><a href="/show/17362/at-deals-acer-predator-cestus-315-now-37">AT Deals: Acer Predator Cestus 315 Gaming Mouse Discounted to $37</a></li>
                    <li ><a href="/show/17361/at-deals-wd-blue-sn570-2tb-ssd-down-to-180">AT Deals: WD Blue SN570 2TB SSD Down to $180</a></li>
                    <li ><a href="/show/17360/solidigm-launches-first-enterprise-ssds-d7p5620-and-d7p5520">Solidigm Launches First Post-Intel Enterprise SSDs: D7-P5620 and D7-P5520</a></li>
                    <li ><a href="/show/17359/kioxia-announces-xg8-client-ssds-pcie-40-and-bics5-for-oems">Kioxia Announces XG8 Client SSDs: PCIe 4.0 and BiCS5 For OEMs</a></li>
                    <li ><a href="/show/17356/tsmc-roadmap-update-n3e-in-2024-n2-in-2026-major-changes-incoming">TSMC Roadmap Update: N3E in 2024, N2 in 2026, Major Changes Incoming</a></li>
            </ul>

        </article>

    <div id="side_ad2">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad2', false); });
            }
        </script>
    </div>

    

        <article class="twitter">
            <h2>TWEETS <img src="/Content/images/twiiter_bird.png" alt="">
            </h2>
            <div class="twitter_box">
                <div class="twitter_cont">

                    <ul>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1522284991941472256">@ServeTheHome Well I'm officially envious.

Though do my eyes deceive me, or is that card a bit longer than the A100?</a></li>
                            <li><a href="https://twitter.com/gavbon86"><span>gavbon86</span></a>: <a href="https://twitter.com/gavbon86/status/1521249458423578625">@anshelsag Thank you kindly, 😁😁😁</a></li>
                            <li><a href="https://twitter.com/gavbon86"><span>gavbon86</span></a>: <a href="https://twitter.com/gavbon86/status/1521243061812084737">Lost two stone in two months!!! Illness + determination = looking fresh 😁 https://t.co/hsdRzyGUvq</a></li>
                            <li><a href="https://twitter.com/gavbon86"><span>gavbon86</span></a>: <a href="https://twitter.com/gavbon86/status/1521242824683003904">@BoMenzzz Living the blonde. Natural?</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1521219335351537665">@FelixCLeClair @anandtech Oh shoot, I didn't even think of that. Thanks!</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1521218756457865216">@Archer_Legend @anandtech There will be content if time allows. Right now I'm still trying to find a new CPU editor.</a></li>
                            <li><a href="https://twitter.com/gavbon86"><span>gavbon86</span></a>: <a href="https://twitter.com/gavbon86/status/1520632249703620610">@svendiggler @EbanieBridges Was hardly decisive, but was a great fight!</a></li>
                            <li><a href="https://twitter.com/gavbon86"><span>gavbon86</span></a>: <a href="https://twitter.com/gavbon86/status/1520599503904116736">@SunnyEdwards It's shocking. Mannix is a dope</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1520495498049703936">@IanCutress @LinusTech @anandtech I have to say say, I didn't see that coming. I had taken count of all the ex-ATer… https://t.co/lqQrORXDzC</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1520492073966706688">@DanMatte There's no native LFC?! 🤦‍♂️</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1514350427092893696">@ricswi I can see the scope for confusion the way it was worded (assumed 320MHz channel width only in 6GHz was comm… https://t.co/nPubI789Vm</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1514022192492658689">@DanMatte @anandtech I don't think we will know until interoperability tests are done :)</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1504623971353866246">@jeffkibuule Not exactly clear from the website - is the panel / app reliant on a cloud server being up? or, can it… https://t.co/aHThC7XjA2</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1503805518199939072">@dave_59 Surely, that legacy code was being evaluated to 7 in a legacy version of the simulator? ;) [ I guess as lo… https://t.co/tfQrZDshW2</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1502744410856964098">@abrasion @nixcraft @ejeler Absolutely no trouble setting up Win 11  without a network connection (I've lost count… https://t.co/Bk1cBFf3Mk</a></li>
                    </ul>

                    
                </div>

                <a class="twitter_follow_btn pie" href="http://twitter.com/anandtech">Follow <span>@</span>ANANDTECH</a>
            </div>
            <strong><img src="/Content/images/twitter_down_arrow.png" alt=""></strong>
        </article>


    <div style="clear: both;">&nbsp;</div>

    <div id="side_ad3">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad3', false); });
            }
        </script>
    </div>

</aside>
        <div class="clear"></div>

        <div class="header_ad hide_resp" id="footer_ad">
            <script type="text/javascript">
                if (screenContext != 'mobile') {
                    tmntag.cmd.push(function () { tmntag.adTag('footer_ad', false); });
                }
            </script>
        </div>
        

    </section>

    <footer class="footer">

        <div class="links">
            <h2>LINKS</h2>
            <div class="clear"></div>
            <ul>
                <li><a href="/">Home</a></li>
                <li><a href="/home/about/">About</a></li>
                <li><a href="http://forums.anandtech.com">Forums</a></li>
                <li><a href="/rss/">RSS</a></li>
                <li><a href="/pipeline/">Pipeline News</a></li>
                <li><a href="/bench/">Bench</a></li>
                <li><a href="https://www.futureplc.com/terms-conditions/">Terms of Use</a></li>
                <li><a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a></li>
            </ul>
        </div>

        <div class="links">
            <h2>TOPICS</h2>
            <div class="clear"></div>
            <ul>
                <li><a href="/tag/cpus">CPUs</a></li>
                <li><a href="/tag/mb">Motherboards</a></li>
                <li><a href="/tag/storage">SSD/HDD</a></li>
                <li><a href="/tag/gpus">GPUs</a></li>
                <li><a href="/tag/mobile">Mobile</a></li>
                <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                <li><a href="/tag/smartphones">Smartphones </a></li>
                <li><a href="/tag/memory">Memory</a></li>
                <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
            </ul>
        </div>

        <div class="links link2">
            <ul>
                <li><a href="/tag/displays">Displays </a></li>
                <li><a href="/tag/mac">Mac </a></li>
                <li><a href="/tag/systems">Systems </a></li>
                <li><a href="/tag/cloud-computing">Cloud </a></li>
                <li><a href="/tag/tradeshows">Trade Shows </a></li>
                <li><a href="/tag/guides">Guides</a></li>
            </ul>
        </div>

        <div class="links">
            <h2>FOLLOW</h2>
            <div class="clear"></div>
            <ul class="follow">
                <li>
                    <a href="http://www.facebook.com/AnandTech/">
                        <img src="/Content/images/icon-facebook2.png" alt="" /><span>Facebook</span>
                    </a>
                </li>
                <li>
                    <a href="http://twitter.com/AnandTech">
                        <img src="/Content/images/icon-twitter2.png" alt="" /><span>Twitter</span>
                    </a>
                </li>
                <li>
                    <a href="/rss/">
                        <img src="/Content/images/icon-rss2.png" alt="" /><span>RSS</span>
                    </a>
                </li>
            </ul>
        </div>
        <div class="clear"></div>

        <div class="footer_left">The Most Trusted in Tech Since 1997</div>
        <div class="footer_right">
            <ul>
                <li><a href="/home/about/">About</a></li>
                <li><a href="https://www.futureplc.com/services/advertising/">Advertising</a></li>
                <li class="nomrgn"><a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a></li>                
            </ul>
            <a href="https://www.futureplc.com"><img style="margin-top: 10px;" src="/Content/images/FutureFooterLogo-Transparent.png" alt="purch" /></a>
            <span>Copyright &copy; 2022. All rights reserved.</span>
        </div>
        <div class="clear"></div>
    </footer>

    <div class="rsp_ft">
        <div class="footer_resp">
            <ul class="tabs">
                <li class="click_btn"><a href="#">TOPICS</a></li>
                <li><a href="#">FOLLOW</a></li>
                <li class="right"><a href="#">ABOUT</a></li>
            </ul>
            <div class="clear"></div>
        </div>
        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="topic_box">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/storage">SSD/HDD</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>

                    <div class="topic_box">
                        <ul>
                            <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                            <li><a href="/tag/smartphones">Smartphones </a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
                            <li><a href="/tag/displays">Displays </a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>

                    <div class="topic_box no_mar">
                        <ul>
                            <li><a href="/tag/mac">Mac </a></li>
                            <li><a href="/tag/systems">Systems </a></li>
                            <li><a href="/tag/cloud-computing">Cloud </a></li>
                            <li><a href="/tag/tradeshows">Trade Shows </a></li>
                            <li><a href="/tag/guides">Guides</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
        </section>

        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow left"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="follow_block ctr">
                        <a href="http://www.facebook.com/AnandTech/"><img src="/Content/images/icon-facebook2.png" alt="" />Facebook</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="http://www.twitter.com/AnandTech"><img src="/Content/images/icon-twitter2.png" alt="" />Twitter</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="/rss/"><img src="/Content/images/icon-rss2.png" alt="" />RSS</a>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
        </section>

        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow right"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="follow_block ctr">
                        <a href="/home/about/">About</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/services/advertising/">Advertising</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/terms-conditions/">Terms of Use</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="/account/fullsite?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Show Full Site</a>
                    </div>


                    <div class="clear"></div>
                    <div class="footer_copy">Copyright &copy; 2022. All rights reserved.</div>
                </div>
            </div>
        </section>


        <div class="mobi-footer">
            <div class="mobile"><a href="#">BENCH</a></div>
            <div class="topic_sec">
                <div class="bench_box show_resp2">
                    <div class="bench_carousel show_resp2">
                        <ul>
                            <li><a href="/Bench/CPU"><img src="/Content/images/bench_li_pic1.jpg" alt=""><span>CPU</span></a></li>
                            <li><a href="/Bench/SSD"><img src="/Content/images/bench_li_pic2.jpg" alt=""><span>SSD</span></a></li>
                            <li><a href="/Bench/GPU13"><img src="/Content/images/gpubench2013.jpg" alt=""><span>GPU<br>2013</span></a></li>
                            <li><a href="/Bench/GPU12"><img src="/Content/images/bench_li_pic3.jpg" alt=""><span>GPU<br>2012</span></a></li>
                            <li><a href="/Bench/Smartphone11"><img src="/Content/images/bench_li_pic5.jpg" alt=""><span>Smartphone<br>2011</span></a></li>
                            <li><a href="/Bench/Mobile"><img src="/Content/images/bench_li_pic6.jpg" alt=""><span>Mobile</span></a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                </div>
            </div>
            <div class="mobile"><a href="#">TOPICS</a></div>

            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="topic_box res_topicBox">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/storage">SSD/HDD</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                            <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                            <li><a href="/tag/smartphones">Smartphones </a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="topic_box no_mar res_topicBox">
                        <ul>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
                            <li><a href="/tag/displays">Displays </a></li>
                            <li><a href="/tag/mac">Mac </a></li>
                            <li><a href="/tag/systems">Systems </a></li>
                            <li><a href="/tag/cloud-computing">Cloud </a></li>
                            <li><a href="/tag/tradeshows">Trade Shows </a></li>
                            <li><a href="/tag/guides">Guides</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>

            <div class="mobile"><a href="#">FOLLOW</a></div>
            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="follow_block">
                        <a href="http://www.facebook.com/AnandTech/"><img src="/Content/images/icon-facebook2.png" alt="">Facebook</a>
                    </div>

                    <div class="follow_block">
                        <a href="http://www.twitter.com/AnandTech"><img src="/Content/images/icon-twitter2.png" alt="">Twitter</a>
                    </div>

                    <div class="follow_block width">
                        <a href="/rss/"><img src="/Content/images/icon-rss2.png" alt="">RSS</a>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
            <div class="mobile"><a href="#">ABOUT</a></div>
            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="topic_box no_mar">
                        <ul>
                            <li><a href="/home/about/">About</a></li>
                            <li><a href="https://www.futureplc.com/services/advertising/">Advertising</a></li>
                            <li><a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a></li>           
                            <li><a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a></li>
                            <li><a href="/account/fullsite?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Show Full Site</a></li>
                            <li class="nomar">Copyright &copy; 2022. All rights reserved.</li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>

            </div>

        </div>

    </div>

    <div class="login_popup">
        <div id="inlineLogin">
            <h2>Log in</h2>
            <h3><span id="ilMessage">Don't have an account? <a href="/Account/Register?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Sign up now</a></span></h3>
            <div class="login_left">
                <form action="#">
                    <div class="login_form">
                        <label>Username</label>
                        <input id="UserName" name="UserName" type="text" class="login_field">

                        <label>Password</label>
                        <input id="Password" name="Password" type="password" class="login_field">

                        <label class="fl-lt" style="margin-right: 10px;" for="RememberMe">Remember Me</label>
                        <input class="fl-lt" id="RememberMe" name="RememberMe" type="checkbox" value="true" /><input name="RememberMe" type="hidden" value="false" />
                        <input onclick="DoLogin(); return false;" name="" type="submit" class="login_btn" id="inlineLoginButton" value="LOG IN"><img alt="" src="/Content/images/ajax-loader.gif" id="ilAjaxLoader" />
                        <div class="clear"></div>
                    </div>
                </form>
                <div id="ilLost">
                    <a href="/Account/ResetPassword?r=%2fshow%2f17373%2famd-announces-ryzen-5000-cseries-for-highend-chromebooks">Lost your password?</a>
                </div>
                <div id="ilTerms">
                    We’ve updated our terms. By continuing to use the site and/or by logging into your account, you agree to the Site’s updated <a target="_blank" href="https://www.futureplc.com/terms-conditions/">Terms of Use</a> and <a target="_blank" href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a>.
                </div>
            <div class="clear"></div>
        </div>
</div></div>
    <div id="oop_ad">
        <script type="text/javascript">
            tmntag.cmd.push(function () { tmntag.adTag('oop_ad', false); });
        </script>
    </div>
    <div id="1x1">
        <script type="text/javascript">
            tmntag.cmd.push(function () { tmntag.adTag('1x1', false); });
        </script>
    </div>
    <!-- Quantcast Tag -->
    <script type="text/javascript">
        var _qevents = _qevents || [];

        (function () {
            var elem = document.createElement('script');
            elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
            elem.async = true;
            elem.type = "text/javascript";
            var scpt = document.getElementsByTagName('script')[0];
            scpt.parentNode.insertBefore(elem, scpt);
        })();

        _qevents.push({
            qacct: "p-bduwCJZfRi0AI"
        });
    </script>

    <noscript>
        <div style="display: none;">
            <img src="//pixel.quantserve.com/pixel/p-bduwCJZfRi0AI.gif" border="0" height="1" width="1" alt="Quantcast" />
        </div>
    </noscript>
    <!-- End Quantcast tag -->
    <!-- Begin omniture Beacon -->
        <script id="omnitureProperties" language="JavaScript" type="text/javascript">
            

            var g_o = {};

            g_o.prop15 = "D=v15";
            g_o.eVar15 = "Non Member";
            g_o.prop35 = "";

            g_o.pageName = "anand:edt:17373:AMD Announces Ryzen 5000 C-Series For High-End Chromebooks:pg1";
            g_o.channel = "Editorial";
            g_o.prop2 = "D=v2";
            g_o.eVar2 = "CPUs";
            g_o.prop4 = "D=v4";
            g_o.eVar4 = "News";
            g_o.prop5 = "D=v5";
            g_o.eVar5 = "AMD Announces Ryzen 5000 C-Series For High-End Chromebooks";
            g_o.prop6 = "D=v6";
            g_o.eVar6 = "anand-edt-17373";
                                        
            g_o.prop34 = "CPUs|Acer|AMD|HP|Chromebook|Ryzen Mobile|Ryzen C-Series|Ryzen 5000|Zen3";
                

            //var s_code = s.t(); if (s_code) document.write(s_code);

        </script>
    <!-- End omniture Beacon -->
            <script type="text/javascript">
            var _gaq = _gaq || [];
            _gaq.push(['_setAccount', 'UA-1721979-1']);
            _gaq.push(['_trackPageview']);
            dataLayer.push({ 'OmnitureVars': g_o });

            (function () {
                var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
            })();
        </script>
    
        <script type="application/ld+json">
            {
                "@context": "http://schema.org",
                "@type": "NewsArticle",
                "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://www.anandtech.com/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks"
            },
            "headline": "AMD Announces Ryzen 5000 C-Series For High-End Chromebooks",
            "image": {
                "@type": "ImageObject",
                "url": "https://images.anandtech.com/doci/17373/AMD%20Ryzen%205000%20C%20Series%20For%20Chromebooks_678x452.jpg",
                "height": "452",
                "width": "678"
            },
            "url": "https://www.anandtech.com/show/17373/amd-announces-ryzen-5000-cseries-for-highend-chromebooks",
            "author": {"@type": "Person","name": "Gavin Bonshor"},
            "publisher": {
                "@type": "Organization",            
                "@id" : "#AnandTechOrg",
                "name": "AnandTech",
                "url": "https://www.anandtech.com",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://www.anandtech.com/content/images/rss_logo.png",
                    "width": "400",
                    "height": "400"
                }
            },
            "ArticleSection": "CPUs",
            "datePublished": "2022-05-05T20:30:00Z",
            "dateModified": "2022-05-05T20:30:00Z",
            "description": "In September 2020, AMD released its Ryzen 3000 C-series for Chromebooks, a line up of budget-priced chips based on the 12nm Picasso (Ryzen+) architecture..."
            }
        </script>



<!--  .20 -->

</body>
</html>
