Many thanks to...

We must thank the following companies for kindly providing hardware for our test bed:

Test Setup

Test Setup
Processor Intel Core i7-4770K ES
4 Cores, 8 Threads, 3.5 GHz (3.9 GHz Turbo)
Motherboard ASRock Z97 Extreme6
Cooling Corsair H80i
Thermalright TRUE Copper
Power Supply OCZ 1250W Gold ZX Series
Corsair AX1200i Platinum PSU
Memory G.Skill RipjawsZ 4x4 GB DDR3-1600 9-11-9 Kit
Memory Settings 1600 9-11-9-27 1T tRFC 240
Video Cards MSI GTX 770 Lightning 2GB (1150/1202 Boost)
ASUS HD7970 3GB (Reference)
Video Drivers Catalyst 13.12
NVIDIA Drivers 335.23
Hard Drive OCZ Vertex 3 256GB
Optical Drive LG GH22NS50
Case Open Test Bed
Operating System Windows 7 64-bit SP1
USB 2/3 Testing OCZ Vertex 3 240GB with SATA->USB Adaptor

Power Consumption

Power consumption was tested on the system as a whole with a wall meter connected to the OCZ 1250W power supply, while in a single MSI GTX 770 Lightning GPU configuration. This power supply is Gold rated, and as I am in the UK on a 230-240 V supply, leads to ~75% efficiency > 50W, and 90%+ efficiency at 250W, which is suitable for both idle and multi-GPU loading. This method of power reading allows us to compare the power management of the UEFI and the board to supply components with power under load, and includes typical PSU losses due to efficiency. These are the real world values that consumers may expect from a typical system (minus the monitor) using this motherboard.

While this method for power measurement may not be ideal, and you feel these numbers are not representative due to the high wattage power supply being used (we use the same PSU to remain consistent over a series of reviews, and the fact that some boards on our test bed get tested with three or four high powered GPUs), the important point to take away is the relationship between the numbers. These boards are all under the same conditions, and thus the differences between them should be easy to spot.

Power Consumption - Long Idle

Power Consumption - Idle

Power Consumption - OCCT

Long idle and idle power consumption are relatively normal for the Z97 Extreme6, although the load power consumption is 10-20W higher than the other motherboards listed here. We have another motherboard tested but not written up yet which also shows the same as the ASRock though, indicating there may be some power saving implemented on some motherboards but not others, or more fundamental efficiency differences due to components.

Windows 7 POST Time

Different motherboards have different POST sequences before an operating system is initialized. A lot of this is dependent on the board itself, and POST boot time is determined by the controllers on board (and the sequence of how those extras are organized). As part of our testing, we are now going to look at the POST Boot Time - this is the time from pressing the ON button on the computer to when Windows 7 starts loading. (We discount Windows loading as it is highly variable given Windows specific features.)  These results are subject to human error, so please allow +/- 1 second in these results.

POST (Power-On Self-Test) Time - Single MSI GTX 770

Like some of the other Z97 motherboards, the default POST time extends to almost 20 seconds. However when stripped of the extra controllers, the Z97 Extreme6 is a very impressive 6.9 seconds.

ASRock Z97 Extreme6 In The Box, Overclocking System Benchmarks
POST A COMMENT

43 Comments

View All Comments

  • jed1972 - Sunday, February 1, 2015 - link

    Can i use a normal m.2 and ultra m.2 while using dual sli on my asrock z97 extreme 6? Reply
  • Rub9000 - Monday, June 8, 2015 - link

    My biggest problem with this board is how picky it is with hard drives and video cards. I removed a drive (I have four) and wanted to use it to build a computer for my wife. I when I removed it, the motherboard freaked out and I had to format the boot drive is reinstall windows. No clue why. The 2nd thing is I use a Nvidia 660 gtx. (yes I know it is an old card). When I installed it I had to use the Gen 2 option in the bios to get the pc to boot. I contacted ASrock to help figure it out with no help from them at all. I ran into the option by chance and used it. It worked and I could log on. No thanks to ASrock support. They are awful. They even belittled my tech back ground when I posted the question on line. (I have a BSIT and over 20 years in enterprise systems support). All that said, I will not buy from ASrock again. Not a company I want to deal with in the future. Reply
  • xtalx - Friday, October 9, 2015 - link

    I have an issue with this board as well, when trying to boot from my SSD.
    I have the following cards on the board:

    PCIE2 - r9 280x
    m.2 ultra - sm951 512MB
    PCIE4 or 4 - Highpoint RAID 2720SGL

    If I have the HighPoint RAID card connected, after it goes through the bios / drive checks the screen simply goes blank and the cursor flashes in the top left hand corner and Windows 7 doesn't boot. If I press any keys, such as NUM Lock the system just freezes.
    If I remove the card it boots.
    Tried various card alignments, but still no joy.
    This card works fine in my ASROCK AMD chipset board. I've gone through the UEFI and removed all reference of the HP RAID Card from boot options, set the SATA mode to AHCI, but still no joy.
    I'm hoping some one on the ASROCK forum has come across this before and has a solution.
    Reply

Log in

Don't have an account? Sign up now