NVIDIA just released their latest driver updates today, bringing us up to version 344.48. These are WHQL certified drivers, and they're also Game Ready for several upcoming titles. NVIDIA specifically calls out Civilization: Beyond Earth (launching tomorrow), Lords of the Fallen (coming October 28), and Elite: Dangerous (a Kickstarter game currently available in Beta form). You can snag the drivers at the usual place, or if you're like most people and are running a desktop GPU on Windows 7/8.1 64-bit, here's the direct link; the drivers are also available for most NVIDIA laptops.

Looking over the complete release notes, the 344.48 drivers also bring DSR (Dynamic Super Resolution) support to Kepler and Fermi GPUs, there are a few tweaks to upcoming games (e.g. Assassin's Creed Unity notes that control panel FXAA is disabled), and SLI profiles have been added for ten new games. There are no specific details on performance improvements with the new drivers, which is insteresting as usually about a month or two after a major GPU launch (i.e. GM204), NVIDIA will further refine their drivers to extract more performance; perhaps we'll see some performance enhancements in the near future for GM204 owners.

Source: NVIDIA

POST A COMMENT

41 Comments

View All Comments

  • Samus - Wednesday, October 22, 2014 - link

    Wow, all this anger over non-NVidia PhysX support...it's like calling AMD shitty because NVidia doesn't have mantel support.

    Every company have their proprietary selling point.

    In other news, I'm angry my Ford truck doesn't take the superior hydraulic transmission mounts from the GM Silverado. Damn you GM for Ford not being compatible with your parts! What bastards!
    Reply
  • beginner99 - Thursday, October 23, 2014 - link

    >Wow, all this anger over non-NVidia PhysX support...it's like calling AMD shitty because NVidia doesn't have mantel support.

    No it isn't. Because NV could add mantel support if the wanted, PhysX in contrast isn't open and has to be licensed and paid for.
    Reply
  • mathijs727 - Thursday, October 23, 2014 - link

    Nvidia can't add mantel support because it's closed source. Not that they want to, but ATM it's technically impossible to add mantel support.

    Mantel WILL be open (at least that's what AMD says) but at the moment it's closed source. In my opinion AMD just says that so less informed people think they're any better then Nvidia, while they're equally "bad" (i think these kind of things are unique selling points, they dont have to share everything).
    Reply
  • chizow - Thursday, October 23, 2014 - link

    @mathijs727 Exactly. It's just lip service on AMD's part so that their minions regurgitate misinformation and they don't come off as hypocritical, given they have always tried to position themselves as the Open People's Choice for Free Opensauceawesomeness. Reply
  • chizow - Thursday, October 23, 2014 - link

    @beginner99, No Nvidia couldn't support Mantle even if they wanted to (they don't), Mantle is still closed and proprietary, just ask Intel or the various other Devs that are not on AMD's approved partner list.

    http://techreport.com/news/26682/intel-asked-amd-f...

    Simple answer is Nvidia does not want to QA PhysX with a secondary dGPU renderer, and who would blame them? If someone has a problem with PhysX with an AMD primary graphics card, they will come to Nvidia for support, not AMD.
    Reply
  • Jorsher - Thursday, October 23, 2014 - link

    It's not the same at all.

    PhysX could work with any GPU, but nVidia wants you to buy their hardware for it -- I could sort of understand that. However, disabling PhysX acceleration on nVidia hardware just because you have a competing GPU in your system is a straight douche move.

    Another example is G-sync. While AMD is allowing their competing freesync to work with nVidia products and not requiring fees for display manufacturer to enable the feature, nVidia requires they pay a license and purchase additional components.
    Reply
  • Godlygamer24 - Thursday, October 23, 2014 - link

    AFAIK that is false. AMD states on their Project FreeSync FAQ that it's only compatible with THEIR GPUs. NVIDIA GPUs aren't compatible. Reply
  • ahaahaaah - Thursday, October 23, 2014 - link

    If Nvidia cards isn't compatible, it's a technical issue that Nvidia can fix because AMD allows anyone, including Nvidia, to use FreeSync. But not the other way round for GSync. Reply
  • MrSpadge - Thursday, October 23, 2014 - link

    Did you read the comments at all? The equivalent point is that your green Ford truck would refuse to work because you have a red GM truck in the same garage. It's not about running PhysX on AMD / Intel GPUs, it's about nVidia stopping to "not allow PhysX on their own GPU if another GPU is present, even if it has nothing to do with the game". Reply
  • chizow - Thursday, October 23, 2014 - link

    @MrSpadge: No, it's more like having a farm with chickens and pigs, there's no problems when you raise them set apart, but if you put them into the same pen they will often be just fine....but othertimes, you might run into problems.

    Better to just keep them apart.
    Reply

Log in

Don't have an account? Sign up now