Battlefield: Bad Company 2

The latest game in the Battlefield series - Bad Company 2 – remains as one of the cornerstone DX11 games in our benchmark suite. As BC2 doesn’t have a built-in benchmark or recording mode, here we take a FRAPS run of the jeep chase in the first act, which as an on-rails portion of the game provides very consistent results and a spectacle of explosions, trees, and more.

Even more so than HAWX, Bad Company 2 marks the closest we’ve seen the GTX 560 and the 6950 1GB. At 1920 the 6950 has a lead of under a frame per second, and it’s not until 1680 that we see the GTX 560 take any kind of lead. In this case both cards just pass the all-important 60fps mark at 1920, representing the bottom necessary for (more or less) fully fluid gameplay.

While we’re not generally interested in 2560 with the GTX 560, it is the only resolution that we run our Waterfall benchmark on, so we’ll quickly comment. NVIDIA normally does quite well here and the GTX 560 is no exception – even though it loses at this resolution on average, it’s 30% faster when it comes to minimums. We’ve seen the minimums in Crysis go the other way, so minimums seem just as game-dependent as the averages with all things considered.

Civilization V STALKER: Call of Pripyat
POST A COMMENT

88 Comments

View All Comments

  • ImSpartacus - Tuesday, January 25, 2011 - link

    Page one, first chart, the 560 Ti is "$149" instead of "$249".

    Although, I kinda prefer the former.
    Reply
  • alcortez - Tuesday, January 25, 2011 - link

    ...wow a 460 for negative $160.
    I want in on that. ;)
    Reply
  • loubarouba - Tuesday, January 25, 2011 - link

    lol thats definitely an approximately sign (~)...unless of course i was late and has already been edited to that.. Reply
  • 7Enigma - Tuesday, January 25, 2011 - link

    Listed at $149 when you meant to write $249. Reply
  • 7Enigma - Tuesday, January 25, 2011 - link

    1st chart to clarify. Reply
  • vol7ron - Tuesday, January 25, 2011 - link

    I think ImSpartacus beat you to it ;) Reply
  • ImSpartacus - Tuesday, January 25, 2011 - link

    Yeah, I was secretly hoping to be the first to mention that. I feel special!

    .)
    Reply
  • Rocket321 - Tuesday, January 25, 2011 - link

    pg. 16 - Series Load Voltage chart has wrong title. Reply
  • 7Enigma - Tuesday, January 25, 2011 - link

    what's crazy is that when I posted and refreshed the page I was the only comment. It wasn't until page 3-4 of this review (as I was reading after the comment post) that I noticed yours was there so there is some lag between when a post is made and when others see it (even though you see it right away). I wish we had a time stamp feature on the post! :) Reply
  • maniac5999 - Tuesday, January 25, 2011 - link

    So the GTX 560 Ti has a 4004mhz DATE rate? Wow, it sure gets around. (chart on P1) ;-) Reply

Log in

Don't have an account? Sign up now