I should have known better. I’d read enough online posts to know that the in-place upgrade from XP to Vista can be problematic, particularly if your XP system registry has grown to huge proportions. My own personal experience with a Vista upgrade had been moderately successful, but even that system was eventually nuked and a clean Vista install performed.

So here was a PC, with lots of fairly useless (from my perspective), but fun (from her perspective) background tasks running under XP. In goes the Vista upgrade.

Did I mention that this system had 2GB of system RAM?

Within two weeks, her system had pretty much become unusable. I scanned it with several malware detectors, and other than complaints about a couple of adware items, there were no Trojans or viruses found. So the problem really came down to an already overloaded Windows XP system that had developed massive registry and hard drive bloat after the Vista in-place upgrade. So I decided to nuke and start over.

One of the cardinal rules of troubleshooting is: change only one variable at a time.

Unfortunately in my hubris, I ignored that rule. I put her system on the bench, swapped out 2GB of Kingston DDR3 RAM for a pair of Corsair 2GB DDR3 modules. I then swapped out the QX6850 for an E8500 3.16GHz dual core CPU.

When I powered the system up, I got no POST, but the fans spun up. Also, the PC beeper didn’t beep. This is, as anyone who has built systems will tell you, one of the most ambiguous and frustrating types of errors.

So I popped her old CPU back in and rebooted.

Same thing.

So I put the old memory back in, and the system POSTed properly. I checked her BIOS on the P5Q3 motherboard, and found out it was still running the 0704 BIOS. That BIOS predated Intel’s 45nm CPUs. On top of that, if you read the summaries of the various BIOS updates, you also see a number of them with text that reads “enchances compatibility with certain memory.”

Flashing the BIOS fixed both the CPU and memory issues. At that point, a clean install of Windows 7 proceeded without any problems.
 
 

Lessons (re)learned:

  • Before upgrading CPUs or memory, check the BIOS version
  • Never change more than one item of hardware at a time without testing it.
Index The Constantly Crashing P7P55D
POST A COMMENT

109 Comments

View All Comments

  • loydcase - Wednesday, January 13, 2010 - link

    For what it's worth, my daughter doesn't just play flash games. While Torchlight is not a big system hog, she also plays games like NeverWinter Nights 2, Titan Quest, Sins of a Solar Empire and other RTS and RPG titles. Reply
  • glockjs - Friday, January 15, 2010 - link

    you just named a slew of games that a 9800pro could easily handle :p Reply
  • Finally - Wednesday, January 13, 2010 - link

    [quote]shows the reality we go through[/quote]

    I'd rather state it this way:
    This article shows the reality PC-incometent people have to go through, on a regular basis.

    I'd say it's pretty hard to find a non-marketing-related article on the web that recommends going for that upgrade option, especially if you have a basement full of hi-end hardware and close to limitless software supplies at hand like the author here...
    Reply
  • Mugur - Wednesday, January 13, 2010 - link

    Hi,

    Just a quick comment regarding the first case: that machine needed just a clean Windows 7 installation (or even a clean Vista installation). No need to replace an "old" quad core with a "new" dual core...

    And never do an upgrade XP - Vista or XP - 7, or even Vista - 7... Just clean installations.
    Reply
  • masterbm - Wednesday, January 13, 2010 - link

    The reminded me of my own experience of that. I have nforce 3 board that had suffered from various it seemed every 3 or 4 months and Then would be fine. Well last week it turned out that issue came from sata controller that was no longer function like it should. But I I did replace the core(ram,cpu,motherboard) of the machine anyway. It is time retire it. Reply
  • svrmstr - Wednesday, January 13, 2010 - link

    Thanks for writing this article! I've experienced what you’re talking about with the first system.

    I have a P5Q3 Deluxe with 2 GB Corsair memory, a Q9550 and a Radeon 4870. I must say that this motherboard is extremely quirky when it comes to memory. I had to return 2 pairs of Corsair RAM before I got a set that would post - each pair that Newegg sent me was different, because they were being discontinued almost as quickly as they were released. Even after I got the system to POST with the 3rd set, I encountered lots of memory errors, but these errors weren't due to bad RAM chips, as I discovered using MemTest86+. I should mention that at the time, the RAM was on the QVL list, although that list has since gone through numerous revisions.

    I spent a solid week researching and learning everything I could about the motherboard, quad-core CPUs and overclocking. (I wasn't trying to overclock at first, but such information would help me understand exactly what had to be done.) A few articles on AnandTech that dealt with Asus motherboards, overclocking and BIOS settings definitely pointed me in the right direction. Along with a couple of lengthy guides to overclocking with quad-core CPUs from other sources, I gained enough knowledge to make the system stable.

    In the end, it involved fine-tuning the BIOS, setting just about every option manually. This meant many long hours of trial and error. As it turned out, the CPU settings required the most tweaking. Getting the right VCORE, PLL and GTL voltages, plus adding a 100ns delay really made a difference – the northbridge settings were also sensitive. It wasn’t a matter of faulty RAM, as was the symptom, rather instabilities with the system as a whole. Individually each part performed flawlessly, but put them and you create a monster time sink. Notably, when I swapped in a Core 2 Duo E8400, all the memory errors went away. That’s when I decided to really focus on the CPU settings. Honestly, this motherboard doesn’t have reliable automatic settings, especially when you’re using a Core 2 Quad. Let me add that I’ve used every BIOS revision since 1702 and they’ve all performed the same for me.

    Now I’m running at 3.4 GHz core speed, 1600 MHz FSB and 1600 MHz memory. I wanted so badly to give up in favor of building a newer, better system, but it just wasn’t in my budget. I hope that my story isn’t too long; I wanted to share what I could. Here are links to some of the articles I read:
    http://www.ocztechnologyforum.com/forum/showthread...">http://www.ocztechnologyforum.com/forum...354d2fa1...
    http://www.ocztechnologyforum.com/forum/showthread...">http://www.ocztechnologyforum.com/forum/showthread...
    http://www.ocztechnologyforum.com/forum/showthread...">http://www.ocztechnologyforum.com/forum...354d2fa1...
    http://www.anandtech.com/mb/showdoc.aspx?i=3309&am...">http://www.anandtech.com/mb/showdoc.aspx?i=3309&am...
    http://www.anandtech.com/mb/showdoc.aspx?i=3129&am...">http://www.anandtech.com/mb/showdoc.aspx?i=3129&am...
    http://www.benchzone.com/page.php?al=Asus_P5Q3_Del...">http://www.benchzone.com/page.php?al=Asus_P5Q3_Del...
    Reply
  • nicknomo - Wednesday, January 13, 2010 - link

    I've had the same experience.. I've never really ran into memory that didn't work in a machine after some degree of tweaking in the BIOS.

    I think that is an important lesson to learn, and a much better solution then constantly RMA'ing parts.

    Just by looking at the reviews in newegg, I can see that most RAM incompatability issues seems to happen with modules that require higher voltages. With the advent of O/C'ing, a lot of manufacturers make memory that will only boot .2 or .3 volts above what a normal DIMM operates at.

    Other problems usually stem from the motherboard reading the SPD of the modules and incorrectly setting the timings. Either way, bumping up the voltage on the memory and setting the timings and clock speed manually will often fix 99% of these problems..
    Reply
  • yyrkoon - Thursday, January 14, 2010 - link

    I have. That is, whenever I get CRC errors, or corrupt files, the first thing I do is check the BIOS settings for the memory to make sure they're correct. When I build a system the first thing I do after the first POST is to check to make sure these settings are correct. timings, as well as voltage.

    I have however had bad sticks of memory from certain manufactures that I now try to avoid like the plague. They have good parts too, but I would rather not play a guessing game when trying to set up a new system.

    Even my own favored brand rarely seems to relay the proper information to many a motherboard, so perhaps this is where / why I picked up this habit.

    Reply
  • yonzie - Wednesday, January 13, 2010 - link

    A few years ago I had a pair of MSI 945G mATX boards heading for a server.
    The harddrive I planned to use for one of the servers consistently killed the board.
    It worked fine in other boards, the MSI board worked fine with other drives.
    The combination of this particular drive and motherboard model consistently killed the board dead. Not helping troubleshooting, it worked fine on the initial boot, then it was gone.
    Reply
  • biostud - Wednesday, January 13, 2010 - link

    One of my friends had the same problem with the i7 and corsair memory, to get the system stable the memory had to run 1066Mhz, otherwise it would crash at random. Reply

Log in

Don't have an account? Sign up now