Ethernet Performance

Ethernet Performance is tested using a procedure first described in a VIA white paper. The Windows 2000 Driver Development Kit (DDK) includes a useful LAN testing utility called NTttcp. We used the NTttcp tool to test Ethernet throughput and the CPU utilization of the various Ethernet Controllers used on the nForce4 Ultra motherboards.

We set up one machine as the server; in this case, an Intel box with an Intel CSA Gigabit LAN connection. Intel CSA has a reputation for providing fast throughput and this seemed a reasonable choice to serve our Gigabit LAN clients. At the server side, we used the following Command Line as suggested by the VIA whitepaper on LAN testing:
Ntttcps - m 4,0, -a 4 - l 256000 - n 30000
On the client side (the motherboard under test), we used the following Command Line:
Ntttcpr - m 4,0, -a 4 - l 256000 - n 30000
At the conclusion of the test, we captured the throughput and CPU utilization figures from the client screen.

Ethernet Throughput

Ethernet Overhead

Earlier reviews have already measured the performance advantage of PCI Express Ethernet compared to PCI Ethernet in Gigabit LAN performance. The ATI Crossfire AMD uses the Marvel 88E8052 Ethernet on the PCIe bus. The Marvel used by ATI competes very well with other PCIe Gigabit Ethernet with a throughput in the 950 Mb/sec range. CPU utilization was a very high 53% in a field where every Gigabit Ethernet controller on the PCIe bus measures CPU utilization of 35% to 56%.

CPU utilization measurements for Gigabit Ethernet can be somewhat misleading, since they measure the percentage of CPU tie-up at sustained Gigabit receiving. In reality, it would be very rare that you would actually see sustained Gigabit transmission levels on your PC. For that reason, you should put the measured CPU utilization of Gigabit PCIe LAN in perspective. It will almost always be much lower than what we have measured.

Firewire and USB Performance Audio Performance
POST A COMMENT

40 Comments

View All Comments

  • Starcraftfreak - Friday, September 30, 2005 - link

    So you are saying, the Board supports the dividers for DDR500 also on a Revision C core? I can remember when you published an article explaining it's a new feature of Revision E. Please clarify. Reply
  • SLI - Wednesday, September 28, 2005 - link

    Everything I have seen thus far on the ATI chipset points to the FSB dropping to DDR333 *IF* you populate all 4 DIMM slots (with DDR400 RAM) This was an issue at the CPU level with AMD Athalon on board memory controller (at first) but has been addressed with the newer steppings. VIA and Nvidia chipsets have support for DDR400 with all 4 slots populated. This is a very important aspect to me and it needs to be addressed. Reply
  • Wesley Fink - Wednesday, September 28, 2005 - link

    It was addressed in tRAS and Memory Stress Tests in the review - p.5. We had no trouble with 4 dimms at DDR400, though we did have to drop to 2T with 4 dimms as we do on every other AMD chipset. This is more a function of the on-CPU memory controller. Reply
  • sxr7171 - Wednesday, September 28, 2005 - link

    I don't get it. We switched to SATA to get worse performance? SATA performed worse than IDE in every single benchmark. Reply
  • Scarceas - Tuesday, September 27, 2005 - link

    I'd like to know what happens when you try two 6800s in a crossfire motherboard...

    I'm also curious about what happens why you try crossfire graphics cards on an NF4 SLI motherboard...

    Early on I heard rumors that the motherboard implementation would be similar between the two and that mixing motherboard/graphics manufacturers *might* be possible...

    Now the hardware is showing up and no one has tried it?
    Reply
  • vailr - Tuesday, September 27, 2005 - link

    Check: page 11 "Ethernet Performance" has format errors:
    http://www.anandtech.com/cpuchipsets/showdoc.aspx?...">http://www.anandtech.com/cpuchipsets/showdoc.aspx?...
    Copied & pasted:
    It will almost always be <em>much</em> lower than what we have measured.<br /> <br /> </span> </div> <div class="adcontainer"></div> <table border="0" width="100%"> <tr> <td align="right" colspan="2"> <table border="0" cellpadding="0" cellspacing="0"> <tr> <td><strong><a href="showdoc.aspx?i=2542&amp;p=12" class="smalllink">Audio
    Reply
  • tanekaha - Wednesday, September 28, 2005 - link

    Ethernet page has same problem as b4 here
    I`m using firefox latest beta and the browser considers the page done after this line.

    Ntttcpr - m 4,0,


    I guess u use a template for these reviews I had exactly the same prob with ( and commented similarly ) with I think the asrock dual article.
    I guess not many others are getting this prob but I`m glad 2 see some! else has a prob and not just me.
    What browser are u using ?
    Wesley have u tried 2 view the article with firefox beta ? or even firefox ?
    Reply
  • Wesley Fink - Thursday, September 29, 2005 - link

    Articles are created in a document engine by our Web Editor, from basic information layouts we send the Web Editor. The engine generates HTML code. We don't individually generate the code for articles. Any problems with viewing the pages should be emailed to our webmaster Jason.Clark@anandtech.com Reply
  • tanekaha - Thursday, September 29, 2005 - link

    Thanks for the replies gents
    I am not using any blockers or extentions .. apart from FF default pop up blocker.
    I will mail jason with the facts (as I see them)
    I`ll also send the info to the FF team
    THX again
    tanekaha
    Reply
  • JarredWalton - Wednesday, September 28, 2005 - link

    If you're using any extensions to block ads or other content, you might want to try disabling those. I've been using Firefox for over a year now, and I don't have any issues with the pages. (Some pages render improperly the first time and I need to hit refresh, but that's generally only on long pages, and it seems more of a FF bug than anything.) Reply

Log in

Don't have an account? Sign up now