
<!DOCTYPE html>
<html>
<!--[if IE 6]> <html class="ie6"> <![endif]-->
<!--[if IE 7]> <html class="ie7"> <![endif]-->
<!--[if IE 8]> <html class="ie8"> <![endif]-->
<!--[if IE 9]> <html class="ie9"> <![endif]-->

<head>
    <!-- Google Tag Manager -->
    <script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PV2DVS');</script>
    <!-- End Google Tag Manager -->
    <script type="text/javascript" src="/Scripts/mobile.min.js"></script>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0" />
        <meta name="application-name" content="AnandTech" />
    <meta name="google-site-verification" content="QejUZTJaqCr781DA0W_JNGjf4wS2xyffL3ohvIuRESc" />
    <meta property="article:publisher" content="https://www.facebook.com/AnandTech" />
    <link rel="shortcut icon" href="/favicon.ico" />
    <link rel="apple-touch-icon" sizes="144x144" href="/content/images/podcast_a_huge.png" />
    <link rel="alternate" type="application/rss+xml" title="RSS Feed for AnandTech.com" href="/rss/" />

    <title>CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards</title>                                                                            
     <link href="/Content/atfonts.css" rel="stylesheet" type="text/css">
    

    <!--[if IE]><style type="text/css">.pie {behavior:url(/Content/PIE.htc);}</style><![endif]-->
    <link href="/Content/css?v=813oG_8nNyCZXz7kVAe5eS_3v4I3z_2YsaGf_j29ZEg1" rel="stylesheet"/>

<link href="/Content/resp?v=bLpsGHlbt2J0jFe7q4kOjMR6XTWKxEGuyW8fHKDd5HM1" rel="stylesheet"/>
    <!--[if lt IE 9]>
        <link type="text/css" href="/content/ie8.css" rel="stylesheet" />
        <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.6.2pre/html5shiv.js"></script>
    <![endif]-->
    <script src="/bundles/jquery?v=guGiAVIp0f1T2TxJO-1NYkUT4F2gOxZwD3D5fOxH8tI1"></script>

    <script src="/bundles/javascript?v=3zoMUnHQHQfKEAEU_MI-Vwh0i7NhmCdIOW4S7phdnJo1"></script>

    
    <script type='text/javascript' src="/Scripts/dynamic.js"></script>

    <script type="text/javascript">
        var tmntag = tmntag || {};
        tmntag.cmd = tmntag.cmd || [];
        (function() {
            var tmnhead = document.createElement('script');
            tmnhead.async = true;
            tmnhead.type = 'text/javascript';
            tmnhead.src = ('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(tmnhead, node);
        })();
        tmntag.cmd.push(function () {
            if (screenContext != 'mobile') {
                tmntag.placement('2002');
            } else {
                tmntag.placement('2012');
            }
                tmntag.target({ "ccat1": "mb" });
            tmntag.target({ "ctype": "pipeline" });
                tmntag.target({ "kw": "mb,asrock,tradeshows,alder-lake,lga1700,ces-2022,b660,h670,value-series,h610,h670m-itxax,b660m-itxac,b660m-hdvpd5,b660m-hdv,h610m-itxac,h610m-hvs,h610m-hdvpd5,h610m-hdvm2,h610-hdv" });

            tmntag.start();
        });
    </script>

    
        <link rel="canonical" href="https://www.anandtech.com/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards" />
            <link rel="shortlink" href="https://www.anandtech.com/show/17181" />
        <meta property="og:title" content="CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards" />
    <meta property="og:type" content="article" />
    <meta property="og:url" content="https://www.anandtech.com/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards" />
    <meta property="og:image" content="https://images.anandtech.com/doci/17181/H670M-ITXax(L1)_678x452.jpg" />
    <meta name="author" content="Gavin Bonshor" />
    <meta name="twitter:card" content="fail" />

    <script type="text/javascript">

        var loggedIn = false;
        var isRoot = false;
    </script>
    <script src="/bundles/comments?v=4dsDdpYDBE_hkYPqV3fRU23zZmeXjfy10FIyxvSlyEk1"></script>

    <script type="text/javascript">

        $(document).ready(function () {
            $('a.icAddComment').click(DoTopPost);

        });

    </script>


</head>
<body>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PV2DVS"height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <!-- Begin comScore Tag -->
    <script>
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6035753" });
        (function () {
            var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
    <noscript>
        <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035753&cv=2.0&cj=1" />
    </noscript>
    <!-- End comScore Tag -->
    <header class="header">
        <div class="header_top">
            <div class="header_ad" id="header_ad">
                <script type="text/javascript">
                    if (screenContext != 'mobile') {
                      tmntag.cmd.push(function () { tmntag.adTag('header_ad', false); });
                    }
                </script>
            </div>
            <div class="logo">
                <a href="/">
                    <img src="/Content/images/logo2.png" alt="" />
                </a>
            </div>
            <div class="header_top_right">
                <div class="search_area">
                    <form action="/SearchResults" method="get">
                        <div class="search">
                            <input name="q" type="text" class="search_field">
                            <input name="" type="submit" class="search_btn" value="search">
                            <div class="clear"></div>
                        </div>
                        <div class="login">
                                <span id="loginHeader" style="display: none;">
                                    Welcome <a href="/Account/Details"><b><span id="loginUser"></span></b></a>
                                    <a href="/Account/Logout?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Log out</a>
                                </span>
                                <span id="logoutHeader">
                                    <a id="loginTop" href="/Account/Login?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Login</a>
                                    <a href="/Account/Register?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Register</a>
                                </span>
                        </div>
                        <div class="clear"></div>
                    </form>
                </div>

                    <div class="header_right_btm">
                        <span>
                            <a href="http://www.twitter.com/AnandTech">
                                <img src="/Content/images/icon-twitter.png" alt="" />
                            </a>
                            <a href="http://www.facebook.com/AnandTech/">
                                <img src="/Content/images/icon-facebook.png" alt="" />
                            </a>
                            <a href="/rss/">
                                <img src="/Content/images/icon-rss.png" alt="" />
                            </a>
                        </span>

                        <ul>
                            <li><a href="/home/about/">ABOUT</a></li>
                            <li><a href="/bench/">BENCH</a></li>
                            <li><a href="http://forums.anandtech.com">FORUMS</a></li>
                            <li><a href="/tag/podcast">PODCAST</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
            </div>
            <div class=" clrflt"></div>
        </div>

        <div class="header_top_resp">
            <div class="logo_resp">
                <a href="/"><img src="/Content/images/logo_resp.png" alt="" /></a>

            </div>
            
            <div class="header_top_resp_right">

                <a class="search_icon" href="#"></a>
                <div class="drop_down_search">
                    <span class="blk"></span>
                    <form action="/SearchResults" method="get">
                        <div class="search">
                            <input name="q" type="text" class="search_field">
                            <input name="" type="submit" class="search_btn" value="search">
                            <div class="clear"></div>
                        </div>
                    </form>
                </div>
                <a class="home" href="#"></a>
                <div class="drop_down_home ">
                    <span class="blk"></span>
                    <a href="/home/about/">ABOUT</a>
                    <a href="/bench/">BENCH</a>
                    <a href="http://forums.anandtech.com">FORUMS</a>
                    <a href="/tag/podcast">PODCAST</a>
                    <a id="loginTopMobile" href="/Account/Login">LOGIN</a>
                    <a href="/Account/Register">REGISTER</a>
                </div>
                <a class="nav_icon show_resp2" href="#"></a>
                <div class="drop_down_nav">
                    <span class="blk"></span>
                    <div class="navmobile ignoreclick"><a href="#">PC Components<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/ssd">SSDs</a></li>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSUs</a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                            <li><a href="/tag/nas">NAS</a></li>
                            <li><a href="/tag/storage">Storage</a></li>
                        </ul>
                    </div>
                    <div class="navmobile ignoreclick"><a href="#">Smartphones &amp; tablets<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/smartphones">Smartphones</a></li>
                            <li><a href="/tag/tablets">Tablets</a></li>
                            <li><a href="/tag/huawei">Huawei</a></li>
                            <li><a href="/tag/htc">HTC</a></li>
                            <li><a href="/tag/samsung">Samsung</a></li>
                            <li><a href="/tag/google">Google/Android</a></li>
                            <li><a href="/tag/microsoft">Microsoft</a></li>
                            <li><a href="/tag/apple">Apple</a></li>
                            <li><a href="/tag/soc">SoCs</a></li>
                        </ul>
                    </div>
                    <div class="navmobile ignoreclick"><a href="#">Systems<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/tag/laptops">Notebook Reviews</a></li>
                            <li><a href="/tag/desktops">Desktop Reviews</a></li>
                            <li><a href="/tag/mac">Mac Reviews</a></li>
                            <li><a href="/tag/ultrabook">Ultrabooks</a></li>
                        </ul>
                    </div>
                    <div><a href="/tag/enterprise">ENTERPRISE & IT</a></div>
                    <div class="navmobile ignoreclick"><a href="#">GUIDES<span>▼</span></a></div>
                    <div class="nav_sec">
                        <ul>
                            <li><a href="/show/9793/best-cpus">Best CPUs</a></li>
                            <li><a href="/show/9799/best-ssds">Best SSDs</a></li>
                            <li><a href="/show/9798/best-laptops">Best Laptops</a></li>
                            <li><a href="/show/9770/best-android-phones">Best Android Phones</a></li>
                            <li><a href="/show/12050/best-video-cards">Best Video Cards</a></li>
                            <li><a href="/show/12056/best-psus">Best PSUs</a></li>
                            <li><a href="/show/12072/best-motherboards">Best Motherboards</a></li>
                            <li><a href="/show/12058/best-gaming-laptops">Best Gaming Laptops</a></li>
                            <li style="height: 60px !important;"><a href="/show/12061/best-mechanical-keyboards">Best Mechanical Keyboards</a></li>
                            <li><a href="/show/12075/best-consumer-hdds">Best Consumer HDDs</a></li>
                        </ul>
                    </div>
                    <div><a href="/tag/deals">DEALS</a></div>
                </div>
            </div>
        </div>
        
    <nav class="breadcrumb nowidth show_resp2">
        <ul>
            <li>
                <a href="/">Home</a><span>&gt;</span>
                    <a href="/tag/mb">Motherboards</a>
            </li>
        </ul>
        <div class="clear"></div>
    </nav>


        
        <nav class="nav inner_nav animenu">
            <input type="checkbox" id="button">
            <label for="button">Menu</label>
            <ul>
                <li>
                    <a href="#" class="ignoreclick">PC Components<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/cpus">CPUs</a></li>
                        <li><a href="/tag/gpus">GPUs</a></li>
                        <li><a href="/tag/mb">Motherboards</a></li>
                        <li><a href="/tag/ssd">SSDs</a></li>
                        <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSUs</a></li>
                        <li><a href="/tag/memory">Memory</a></li>
                        <li><a href="/tag/nas">NAS</a></li>
                        <li><a href="/tag/storage">Storage</a></li>
                    </ul>

                </li>
                <li>
                    <a href="#" class="ignoreclick">Smartphones &amp; tablets<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/smartphones">Smartphones</a></li>
                        <li><a href="/tag/tablets">Tablets</a></li>
                        <li><a href="/tag/huawei">Huawei</a></li>
                        <li><a href="/tag/htc">HTC</a></li>
                        <li><a href="/tag/samsung">Samsung</a></li>
                        <li><a href="/tag/google">Google/Android</a></li>
                        <li><a href="/tag/microsoft">Microsoft</a></li>
                        <li><a href="/tag/apple">Apple</a></li>
                        <li><a href="/tag/soc">SoCs</a></li>
                    </ul>
                </li>
                <li>
                    <a href="#" class="ignoreclick">Systems<span>▼</span></a>
                    <ul>
                        <li><a href="/tag/laptops">Notebook Reviews</a></li>
                        <li><a href="/tag/desktops">Desktop Reviews</a></li>
                        <li><a href="/tag/mac">Mac Reviews</a></li>
                        <li><a href="/tag/ultrabook">Ultrabooks</a></li>
                    </ul>
                </li>
                <li>
                    <a href="/tag/enterprise" class="">Enterprise & IT</a>
                </li>
                <li>
                    <a href="#" class="ignoreclick">Guides<span>▼</span></a>
                    <ul>
                        <li><a href="/show/9793/best-cpus">Best CPUs</a></li>
                        <li><a href="/show/9799/best-ssds">Best SSDs</a></li>
                        <li><a href="/show/9798/best-laptops">Best Laptops</a></li>
                        <li><a href="/show/9770/best-android-phones">Best Android Phones</a></li>
                        <li><a href="/show/12050/best-video-cards">Best Video Cards</a></li>
                        <li><a href="/show/12056/best-psus">Best PSUs</a></li>
                        <li><a href="/show/12072/best-motherboards">Best Motherboards</a></li>
                        <li><a href="/show/12058/best-gaming-laptops">Best Gaming Laptops</a></li>
                        <li style="height: 60px !important;"><a href="/show/12061/best-mechanical-keyboards">Best Mechanical Keyboards</a></li>
                        <li><a href="/show/12075/best-consumer-hdds">Best Consumer HDDs</a></li>
                    </ul>
                </li>
                <li>
                    <a href="/tag/deals" class="">Deals</a>
                </li>
            </ul>
        </nav>

            <nav class="topic_menu topic_inner" style="width: 280px; padding: 6px 0 0 6px;float: right;">
                <div class="fbholder-fp" style="float:left; margin-right: 15px;"><div class="fb-like" data-href="http://www.facebook.com/AnandTech" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-colorscheme="dark"></div></div>
                <a href="https://twitter.com/anandtech" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false"></a>
                <script>!function (d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (!d.getElementById(id)) { js = d.createElement(s); js.id = id; js.src = "//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); } }(document, "script", "twitter-wjs");</script>

            </nav>
            <nav class="topic_menu topic_inner">
                <ul>
                    
                    <li class="topin_title">TRENDING TOPICS</li>
                            <li class="nosep"><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/intel">Intel</a></li>
                            <li><a href="/tag/amd">AMD</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/asus">Asus</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/socs">SoCs</a></li>
                            <li><a href="/tag/storage">Storage</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                </ul>
                <div class="clear"></div>
            </nav>
    </header>

    <section class="content">
            <section class="main_cont">

                

<div class="breadcrumb_area hide_resp2">
    <nav class="breadcrumb">
        <ul>
            <li><a href="/">Home</a><span>&gt;</span></li>
                <li><a href="/tag/mb">Motherboards</a></li>
        </ul>
        <div class="clear"></div>
    </nav>

    
    <div class="clear"></div>
</div>



<div class="review_blog">
    <div class="blog_top_left">
        <a href="/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards"><h1>CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards</h1></a>
        <span>by <a href="#"><a class='b' href='/Author/200'>Gavin Bonshor</a></a> <em>on January 5, 2022 5:15 PM EST</em> </span>
        <ul class="hide_resp2">
            <li>Posted in</li>
            <li><a href="/tag/mb">Motherboards</a></li>
                <li><a href="/tag/asrock">ASRock</a></li>
                <li><a href="/tag/tradeshows">Trade Shows</a></li>
                <li><a href="/tag/alder-lake">Alder Lake</a></li>
                <li><a href="/tag/lga1700">LGA1700</a></li>
                <li><a href="/tag/ces-2022">CES 2022</a></li>
                <li><a href="/tag/b660">B660</a></li>
                <li><a href="/tag/h670">H670</a></li>
                <li><a href="/tag/value-series">Value Series</a></li>
                <li><a href="/tag/h610">H610</a></li>
                <li><a href="/tag/h670m-itxax">H670M-ITX/ax</a></li>
                <li><a href="/tag/b660m-itxac">B660M-ITX/ac</a></li>
                <li><a href="/tag/b660m-hdvpd5">B660M-HDVP/D5</a></li>
                <li><a href="/tag/b660m-hdv">B660M-HDV</a></li>
                <li><a href="/tag/h610m-itxac">H610M-ITX/ac</a></li>
                <li><a href="/tag/h610m-hvs">H610M-HVS</a></li>
                <li><a href="/tag/h610m-hdvpd5">H610M-HDVP/D5</a></li>
                <li><a href="/tag/h610m-hdvm2">H610M-HDV/M.2</a></li>
                <li><a href="/tag/h610-hdv">H610-HDV</a></li>
        </ul>
    </div>

    <div class="blog_top_right show_resp2">
        <span><a href="#comments">0 <small>Comments</small></a></span>
        | <strong><a class="icAddComment" href="/Comment/NewComment/17181?page=1&commentPage=1&showAllComments=False">Add A Comment</a></strong>
    </div>
    <div class="blog_top_right hide_resp2">

            <span><a href="#comments">0 <small>Comments</small></a></span>
        <strong><a class="icAddComment" href="/Comment/NewComment/17181?page=1&commentPage=1&showAllComments=False">+ Add A<br>Comment</a></strong>
    </div>
    <div class="clear"></div>
</div>


<div class="sidepadding review">

                <div style="margin: 0 auto; text-align: center;">
                    <img src="https://images.anandtech.com/doci/17181/H670M-ITXax(L1)_678x452.jpg" alt="" />
                </div>

            <div style="float: right; margin: 13px 0px 15px 15px;">
                <div id="middle_ad">
                    <script type="text/javascript">
                        if (screenContext != 'mobile') {
                            tmntag.cmd.push(function () { tmntag.adTag('middle_ad', false); });
                        }
                    </script>
                </div>

                <div class="clear"></div>



            </div>


        <div class="articleContent">
            <p>At CES 2022, ASRock unveiled a total of nine Value Series models based on Intel&#39;s latest 600&nbsp;series chipsets,&nbsp;including one H670, three B660, and five H610 models. The ASRock Value Series offers entry-level features and options for users looking to harness the power of Alder Lake on a tight budget, with seven featuring support for DDR4 memory and two with support for the latest DDR5 memory.</p>

<p>One of the things that frustrated&nbsp;users at&nbsp;the initial launch of the Intel Z690 chipset was the lack of value. The Z690 models seem to be and are inherently more expensive than the previous generation. While there have been many theories and explanations floating around various online mediums such as Reddit,&nbsp;it&#39;s hard to deny that motherboards have been skyrocketing in price over the last couple of years. The other obvious pitfall is the current availability and pricing of&nbsp;DDR5 memory.</p>

<p>Enter the Intel H670, B660, and H610 chipsets that do have &#39;less&#39;&nbsp;in terms of features compared to the performance and <a href="https://www.anandtech.com/show/16971/the-intel-z690-motherboard-overview-ddr4-over-30-new-models">premium&nbsp;Z690 chipset</a>, nor do they include over-engineered power deliveries impressive OLED panels like some of the flagships include. One of the things that the&nbsp;new 600 series chipsets do have is value.&nbsp;The ASRock Value Series offers users a lower cost and&nbsp;modest entry point to benefit from the improvements that <a href="https://www.anandtech.com/show/17162/intel-announces-12th-gen-core-alder-lake-22-new-desktops-cpus-8-new-laptoph-cpus">Intel&#39;s 12th generation</a> brings to the table, but without breaking the bank.</p>

<h3>ASRock H670 Value Series Motherboards</h3>

<p>ASRock has announced just one &#39;Value Series&#39; motherboard on the H670 chipset, the mini-ITX sized H670M-ITX/ax. It follows a basic silver and black color theme throughout, and ASRock is advertising an 8-phase Dr.MOS power delivery, with support for up to 64 GB of DDR4-5000 memory across two slots.&nbsp;</p>

<p align="center"><a href="https://images.anandtech.com/doci/17181/H670M-ITXax%28L3%29.jpg"><img alt="" src="https://images.anandtech.com/doci/17181/H670M-ITXax%28L3%29_575px.jpg" /></a><br />
<em>The ASRock H670M-ITX/ac mini-ITX motherboard</em></p>

<p>Some of the most notable features of the ASRock H670M-ITX/ax is an integrated Wi-Fi 6E CNVi, with a Realtek RTL8125BG 2.5 GbE controller, as well as support for two PCIe 4.0 x4 M.2 drives, four SATA ports, and a single full-length PCIe 5.0 x16 slot. It includes one USB 3.2 G2x2 Type-C, two USB 3.2 G2 Type-A, four USB 2.0 ports on the rear panel, and one USB 3.2 G1 Type-C front panel header. It also benefits from a budget Realtek ALC897 HD audio codec that powers three 3.5 mm audio jacks.</p>

<h3>ASRock B660 Value Series Motherboards</h3>

<p>There are three ASRock B660 Value Series motherboards, including two micro-ATX options. The first of these is the ASRock B660M-HDVP/D5, which supports 64 GB of DDR5 memory across two slots and one full-length PCIe 4.0 x16, two PCIe 3.0 x1, and one legacy PCI slot. It also includes one PCIe 3.0 x4 M.2 slot, four SATA ports, a Realtek RTL8111H Gigabit controller, and uses a Realtek ALC897 HD audio codec. However, the&nbsp;B660M-HDVP/D5&nbsp;doesn&#39;t have&nbsp;any USB 3.2 G2 support.</p>

<p align="center"><a href="https://images.anandtech.com/doci/17181/B660M-HDVPD5%28L2%29.jpg"><img alt="" src="https://images.anandtech.com/doci/17181/B660M-HDVPD5%28L2%29_575px.jpg" /></a><br />
<em>The ASRock B660M-HDVP/D5 micro-ATX motherboard with support for DDR5 memory</em></p>

<p>The ASRock B660M-HDV has a slightly different layout and feature set to the B660M-HDVP/D5, with two memory slots capable of supporting up to 64 GB of DDR4-5066 memory. Also included is one PCIe 4.0 x4 M.2, one PCIe 3.0 x4 M.2, four SATA ports, an Intel I219-V Gigabit Ethernet controller, but it lists both a Realtek ALC897 and 887 HD audio codec, which is confusing. Like the B660M-HDVP/D5, the B660M-HDV doesn&#39;t include any form of USB 3.2 G2 connectivity.</p>

<p>ASRock also has the B660M-ITX/ac, which is its only mini-ITX model based on the B660 chipset. It includes one full-length PCIe 4.0 x16 slot, supporting one PCIe 4.0 x4 M.2, and four SATA ports. There are two memory slots with support for up to 64 GB of DDR4-5000, with onboard audio capabilities consisting of a Realtek ALC897 HD audio codec, networking handled by an Intel I219-V Gigabit Ethernet controller, and like the other B660 Value Series models, it doesn&#39;t feature any USB 3.2 G2 connectivity.</p>

<h3>ASRock H610 Value Series Motherboards</h3>

<p>For the most value-focused of Intel&#39;s 600 series chipsets, ASRock has five H610 motherboards available, four micro-ATX, and one mini-ITX model. The first of the micro-ATX models is the ASRock H610M-HDVP/D5, which has support for DDR5 memory, as well as an advertised 5-phase power delivery, a Realtek RTL8111H Gigabit Ethernet port, and a Realtek ALC897 HD audio codec. In terms of PCIe, there&#39;s a full-length PCIe 4.0 x16 slot, two PCIe 3.0 x1 slots, a legacy PCI slot, as well as one PCIe 3.0 x4 M.2 slot and four SATA ports.&nbsp;It also has a Serial COM port on the rear panel, with four video outputs, including one HDMI, one DisplayPort 1.4m, one DVI-D, and one D-Sub.</p>

<p align="center"><a href="https://images.anandtech.com/doci/17181/H610M-HDVM.2%28L2%29.jpg"><img alt="" src="https://images.anandtech.com/doci/17181/H610M-HDVM.2%28L2%29_575px.jpg" /></a><br />
<em>The ASRock H610M-HDV/M.2 micro-ATX motherboard with added Key E M.2 slot for Wi-Fi</em></p>

<p>The ASRock H610M-HDV/M.2 has a black and grey PCB, supporting up to 64 GB of DDR4-3200 memory across two slots. There are&nbsp;one full-length PCIe 4.0 x16 and two PCIe 3.0 x1 slots, one PCIe 3.0 x4 and four SATA ports for conventional storage, and an Intel I219-V Gigabit Ethernet controller, with ASRock advertising both a Realtek ALC897 and 887 HD audio codec. The main feature of the H610M-HDV/M.2 is that it has a Key E M.2 slot for users looking at their own Wi-Fi CNVi.</p>

<p>ASRock also has the&nbsp;H610M-HDV and H610M-HDV models, which have no M.2 slots onboard.&nbsp;Both models feature one full-length PCIe 4.0 x16 slot, one PCIe 3.0 x1 slot, four SATA ports, and a Realtek RTL8111 Gigabit controller instead of the Intel variant. Both of these models use a Realtek RTL8111H Gigabit Ethernet controller, a Realtek ALC897 HD audio codec, with the only difference between the two being that the H610-HDV has a DisplayPort 1.4 video output. Both do, however, include a D-sub and HDMI video output pairing.</p>

<p align="center"><a href="https://images.anandtech.com/doci/17181/H610M-ITXac%28L4%29.jpg"><img alt="" src="https://images.anandtech.com/doci/17181/H610M-ITXac%28L4%29_575px.jpg" /></a><br />
<em>The ASRock H610M-ITX/ac mini-ITX motherboard with a Wi-Fi 5 CNVi</em></p>

<p>The only&nbsp;ASRock&nbsp;Value Series for mini-ITX is the H610M-ITX/ac, with one full-length PCIe 4.0 x16 slot, one PCIe 3.0 x4 M.2 slot, and four SATA ports. ASRock is advertising a 6-phase power delivery, with other features including an Intel I219-V Gigabit Ethernet controller and Wi-Fi 5 CNVi for networking, with a Realtek ALC897 HD audio codec taking care of the board&#39;s audio functionality. Like all of ASRock&#39;s other&nbsp;H610 models, none of these features any type of USB 3.2 G2 connectivity, nor do they include any level of support for USB Type-C.</p>

<p>ASRock hasn&#39;t specified when its H670, B660, and H610 Value Series motherboards will hit retail channels, nor have they provided any pricing.</p>

<p><div class="clear"></div><div class="thumbTagContainer">Gallery: <a href="/Gallery/Album/8093" target="_blank">CES 2022: ASRock Value Series Motherboards, Intel H670, B660, and H610 Announced</a><div class="thumbsList" id="gallery"><ul><li><a href="/Gallery/Album/8093#1" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDV(L1)_thumb.jpg" width="85" height="85" border="0"/></a></li><li><a href="/Gallery/Album/8093#2" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDV(L2)_thumb.jpg" width="85" height="85" border="0"/></a></li><li><a href="/Gallery/Album/8093#3" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDV(L3)_thumb.jpg" width="85" height="85" border="0"/></a></li><li><a href="/Gallery/Album/8093#4" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDV(L4)_thumb.jpg" width="85" height="85" border="0"/></a></li><li><a href="/Gallery/Album/8093#5" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDV(L5)_thumb.jpg" width="85" height="85" border="0"/></a></li><li><a href="/Gallery/Album/8093#6" target="_blank"><img src="https://images.anandtech.com/galleries/8093/B660M-HDVPD5(L1)_thumb.jpg" width="85" height="85" border="0"/></a></li></ul><div class="boxclear"></div></div></div><div class="clear"></div></p>

<p>Source: <a href="https://www.asrock.com/news/index.asp?iD=4794">ASRock</a></p>

        </div>
        <div class="article_links">
            
        </div>
            <div class="clear"></div>
            <div class="fl-lt" style="clear: both; margin: 25px 0px 15px; height: 35px; width:150px;">
                <iframe src="//www.facebook.com/plugins/like.php?href=http://www.anandtech.com/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards&amp;width&amp;layout=button_count&amp;action=like&amp;show_faces=true&amp;share=true&amp;height=21&amp;appId=201944423199922" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:21px;" allowtransparency="true"></iframe>
            </div>
            <div class="fl-lt" style="margin: 25px 0px 15px; height: 35px; width:90px;">
                <div class="g-plusone" data-size="medium"></div>
                <script type="text/javascript">
                    (function () {
                        var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                        po.src = 'https://apis.google.com/js/platform.js';
                        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
                    })();
                </script>
            </div>
            <div class="fl-lt" style="margin: 25px 0px 15px; height: 35px; width:120px;">
                <a href="https://twitter.com/share" class="twitter-share-button" data-lang="en">Tweet</a>
                <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
            </div>
            <div class="fl-rt" style="margin: 22px 0px 15px;">
                <div class="button left"><a href="/print/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards" class="print_article"><span>PRINT THIS ARTICLE</span></a></div>
            </div>
            <div class="fl-rt" style="margin: 22px 8px 15px; height: 0px;">
            </div>
            <div class="clear"></div>
            <div style="text-align: center;" id="resp_middle_ad">
                <script type="text/javascript">
                    if (screenContext == 'mobile') {
                        tmntag.cmd.push(function () { tmntag.adTag('resp_middle_ad', false); });
                    }
                </script>
            </div>


</div>

    <div class="discussion" id="comments">
        
<script type="text/javascript">
    
    $(document).ready(function () {
        window.hasCommenting = true;        
        $('#icTopPost').click(DoTopPost);

        $("#icLoginLink").click(function (e) {
            window.gotoComment = true;

            $.fancybox.open([
                    {
                        href: '#inlineLogin'
                    }
                ], {
                    padding: 0,
                    titlePosition: 'inside',
                    transitionIn: 'none',
                    transitionOut: 'none',
                    afterShow: function (current, previous) {
                        $('#UserName').focus();

                    }
                });

            e.preventDefault();
            return false;

        });
        
        $("#inlineComment").click(function (e) {
            DoComment();
            e.preventDefault();
            return false;
        });

        $("div#comments a.jqc").click(function () {
            $.get(this.href, scrollComments);
            return false;
        });

    });
</script>
<div><a id="commentsAnchor"></a></div>
<ul id="icReplyHolder">
    <li id="replybox" class="blog_post_area" style="display: none;">
        <div class="blog_post_btm">
            <h3>Post Your Comment</h3>
            <span id="icMessage">
                    
                        Please <a id="icLoginLink" href="/Account/Login?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">log in</a> or <a href="/Account/Register?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">sign up</a> to comment. 
                    
                                                                                                                                                                                               
            </span>
            <textarea cols="10" rows="10" class="comment_txtarea" placeholder="Enter your comment" id="CommentInput" name="CommentInput"></textarea>
            <input name="" type="button" id="inlineComment" class="submit_comment_btn" value="Submit Comment" disabled="disabled">
            <img alt="" src="/Content/images/ajax-loader13.gif" id="icAjaxLoader"/>
            <input type="hidden" name="ParentCommentId" id="ParentCommentId" />
            <input type="hidden" name="ReplyLevel" id="ReplyLevel" />
            <input data-val="true" data-val-number="The field ContentId must be a number." data-val-required="The ContentId field is required." id="ContentId" name="ContentId" type="hidden" value="17181" />
            <div class="clear"></div>
        </div>
    </li>
</ul>

<div class="blog_comments">
    
    <a id="icTopPost" href="/Comment/NewComment/17181?page=1&commentPage=1&showAllComments=False" class="print_article top_post">POST A COMMENT</a>
    

    
        <h2>0 Comments</h2>
        <h3><a href="/comments/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">View All Comments</a></h3>
    <ul id="ulComments">


    </ul>
</div>
    <nav class="page_nav">
        <ul>
                        
                                </ul>
    </nav>

    </div>



            </section>


<aside class="sidebar">
    <div id="side_ad">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad', false); });
            }
        </script>
    </div>
    
        <article class="pipeline_stories">
            <div class="pipeline_title">
                <h2><a href="/pipeline">PIPELINE STORIES</a>
                </h2>
                <a href="mailto:tips@anandtech.com">+ Submit News</a>
                <div class="clrflt"></div>
            </div>

            <strong>
                <a href="/show/17183/ces-2022-msi-unveils-the-mag-b660-tomahawk-wifi-ddr4-motherboard">CES 2022: MSI Unveils the MAG B660 Tomahawk WIFI DDR4 Motherboard</a>
                <img src="/Content/images/dell_reveal_arrow.png" alt="">
            </strong>

            <span><a href="/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards</a></span>
            <span><a href="/show/17182/at-deals-sabrent-1tb-rocket-ssd-at-new-low-price-85">AT Deals: Sabrent 1TB Rocket SSD at New Low Price $85</a></span>
                 
            <ul>
                    <li ><a href="/show/17163/ces-2022-asus-zenbook-14-oled-with-latest-amd-barcelo-apu">CES 2022: ASUS Zenbook 14 OLED With Latest AMD Barcelo APU</a></li>
                    <li ><a href="/show/17180/ces-2022-the-asus-rog-zephyrus-g14-for-2022-ryzen-6000-mobile-with-radeon">CES 2022: The ASUS ROG Zephyrus G14 For 2022, Ryzen 6000 Mobile with Radeon Graphics</a></li>
                    <li ><a href="/show/17150/ces-2022-the-asus-rog-flow-z13-a-gaming-tablet-that-s-so-much-more">CES 2022: The ASUS ROG Flow Z13, A Gaming Tablet That&#39;s So Much More</a></li>
                    <li ><a href="/show/17160/ces-2022-asus-zenbook-17-fold-oled-17-inch-foldable-with-thunderbolt-4">CES 2022: ASUS Zenbook 17 Fold OLED, 17 Inch Foldable With Thunderbolt 4</a></li>
                    <li ><a href="/show/17137/ces-2022-asus-unveils-zenbook-14-oled-intel-evo-laptop-with-alder-lake">CES 2022: ASUS Unveils Zenbook 14 OLED, Intel Evo Laptop with Alder Lake</a></li>
                    <li ><a href="/show/17170/ces-2022-corsair-launches-one-i300-gaming-pc-with-intel-core-i9-12900k-and-ddr5">CES 2022: Corsair Launches One i300 Gaming PC with Intel Core i9-12900K and DDR5</a></li>
                    <li ><a href="/show/17172/ces-2022-asus-announce-rog-swift-oled-pg48uq-pg42uq-gaming-monitors">CES 2022: ASUS Announce ROG Swift OLED PG48UQ &amp; PG42UQ Gaming Monitors</a></li>
                    <li ><a href="/show/17177/plugable-introduces-ud6950pdz-triple-4k-hdmi-displayport-docking-station">CES 2022: Plugable Introduces UD-6950PDZ Triple 4K HDMI / DisplayPort Docking Station</a></li>
                    <li ><a href="/show/17178/ces-2022-akasa-introduces-thermal-solutions-for-pcs-and-industrial-applications-">CES 2022: Akasa Introduces Thermal Solutions for PCs and Industrial Applications </a></li>
            </ul>

        </article>

    <div id="side_ad2">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad2', false); });
            }
        </script>
    </div>

    

        <article class="twitter">
            <h2>TWEETS <img src="/Content/images/twiiter_bird.png" alt="">
            </h2>
            <div class="twitter_box">
                <div class="twitter_cont">

                    <ul>
                            <li><a href="https://twitter.com/IanCutress"><span>IanCutress</span></a>: <a href="https://twitter.com/IanCutress/status/1478815097913069574">@philparkbot I think my interview with Mike mentioned K9 earlier than this article:

https://t.co/Yxi0CZPSQq</a></li>
                            <li><a href="https://twitter.com/IanCutress"><span>IanCutress</span></a>: <a href="https://twitter.com/IanCutress/status/1478807855344066562">More Money = More Big Chips. 5nm, 3nm - it's the future. Not sure what semiconductor shortage you're talking about.… https://t.co/6pqEzfcMl8</a></li>
                            <li><a href="https://twitter.com/IanCutress"><span>IanCutress</span></a>: <a href="https://twitter.com/IanCutress/status/1478756944424882185">@aschilling @DavidJBarr Copy paste error. Hanlon's Razor.

https://t.co/H5ent8xmfy</a></li>
                            <li><a href="https://twitter.com/IanCutress"><span>IanCutress</span></a>: <a href="https://twitter.com/IanCutress/status/1478741586368417793">Updated the Laptop CPUs with frequency and turbo power data. For whatever reason there was a half-data slide in the… https://t.co/L9UIXVyVtG</a></li>
                            <li><a href="https://twitter.com/IanCutress"><span>IanCutress</span></a>: <a href="https://twitter.com/IanCutress/status/1478738141607563268">@tweevtran Write your code in Chrome and wait until it crashes / it mistakes a backspace and opens the previous web page</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1478649378755678208">Proud to be part of the engineering team that is bringing these SoCs into the market https://t.co/BafOlUf6cC</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1478174215467507713">CES media days have already started, and AMD is out of the gate with a quick teaser of a Ryzen 6000 Mobile announce… https://t.co/jMtBeCepn2</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1478133106796158978">@Nick_Craver @IanCutress We have all the source vector art. So it wouldn't be much trouble to generate a larger one… https://t.co/fcXOxsvLrB</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1476704972230201344">@IanCutress I have to admit I miss crazy memory devices. They are never quite as useful as they should be, but the engineering is fun to see</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1476475551816716289">I updated my personal rig from Win 10 2004 to 21H1 this evening. If nothing else, there's one nice thing about Wind… https://t.co/sviOF4uTgq</a></li>
                            <li><a href="https://twitter.com/RyanSmithAT"><span>RyanSmithAT</span></a>: <a href="https://twitter.com/RyanSmithAT/status/1476350808241311746">@Guy1ncogn1t0 Eh, no more than any other old SSD. Technically Intel will still be making SSDs for a couple of years</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1471386316503797761">@wavedrom @TudorTimi Running wavedrom self-hosted was quite easy - putting downloaded source code in a folder in an… https://t.co/wOpWasKVfC</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1470441377947217920">@tuanies I bought the same one (it is 1600p, not 1440p). The one thing that is driving me crazy is the uneven heigh… https://t.co/U3mRNqayyM</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1469010165047300098">@IanCutress @linusgsebastian Build your own with Home Assistant.  Or, adopt something like Hubitat. I've been using… https://t.co/nN8IIJ6Ogl</a></li>
                            <li><a href="https://twitter.com/ganeshts"><span>ganeshts</span></a>: <a href="https://twitter.com/ganeshts/status/1464404183855992836">@robertheron https://t.co/XN4L9SodqP (No personal experience with this brand)</a></li>
                    </ul>

                    
                </div>

                <a class="twitter_follow_btn pie" href="http://twitter.com/anandtech">Follow <span>@</span>ANANDTECH</a>
            </div>
            <strong><img src="/Content/images/twitter_down_arrow.png" alt=""></strong>
        </article>


    <div style="clear: both;">&nbsp;</div>

    <div id="side_ad3">
        <script type="text/javascript">
            if (screenContext != 'mobile') {
                tmntag.cmd.push(function () { tmntag.adTag('side_ad3', false); });
            }
        </script>
    </div>

</aside>
        <div class="clear"></div>

        <div class="header_ad hide_resp" id="footer_ad">
            <script type="text/javascript">
                if (screenContext != 'mobile') {
                    tmntag.cmd.push(function () { tmntag.adTag('footer_ad', false); });
                }
            </script>
        </div>
        

    </section>

    <footer class="footer">

        <div class="links">
            <h2>LINKS</h2>
            <div class="clear"></div>
            <ul>
                <li><a href="/">Home</a></li>
                <li><a href="/home/about/">About</a></li>
                <li><a href="http://forums.anandtech.com">Forums</a></li>
                <li><a href="/rss/">RSS</a></li>
                <li><a href="/pipeline/">Pipeline News</a></li>
                <li><a href="/bench/">Bench</a></li>
                <li><a href="https://www.futureplc.com/terms-conditions/">Terms of Use</a></li>
                <li><a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a></li>
            </ul>
        </div>

        <div class="links">
            <h2>TOPICS</h2>
            <div class="clear"></div>
            <ul>
                <li><a href="/tag/cpus">CPUs</a></li>
                <li><a href="/tag/mb">Motherboards</a></li>
                <li><a href="/tag/storage">SSD/HDD</a></li>
                <li><a href="/tag/gpus">GPUs</a></li>
                <li><a href="/tag/mobile">Mobile</a></li>
                <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                <li><a href="/tag/smartphones">Smartphones </a></li>
                <li><a href="/tag/memory">Memory</a></li>
                <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
            </ul>
        </div>

        <div class="links link2">
            <ul>
                <li><a href="/tag/displays">Displays </a></li>
                <li><a href="/tag/mac">Mac </a></li>
                <li><a href="/tag/systems">Systems </a></li>
                <li><a href="/tag/cloud-computing">Cloud </a></li>
                <li><a href="/tag/tradeshows">Trade Shows </a></li>
                <li><a href="/tag/guides">Guides</a></li>
            </ul>
        </div>

        <div class="links">
            <h2>FOLLOW</h2>
            <div class="clear"></div>
            <ul class="follow">
                <li>
                    <a href="http://www.facebook.com/AnandTech/">
                        <img src="/Content/images/icon-facebook2.png" alt="" /><span>Facebook</span>
                    </a>
                </li>
                <li>
                    <a href="http://twitter.com/AnandTech">
                        <img src="/Content/images/icon-twitter2.png" alt="" /><span>Twitter</span>
                    </a>
                </li>
                <li>
                    <a href="/rss/">
                        <img src="/Content/images/icon-rss2.png" alt="" /><span>RSS</span>
                    </a>
                </li>
            </ul>
        </div>
        <div class="clear"></div>

        <div class="footer_left">The Most Trusted in Tech Since 1997</div>
        <div class="footer_right">
            <ul>
                <li><a href="/home/about/">About</a></li>
                <li><a href="https://www.futureplc.com/services/advertising/">Advertising</a></li>
                <li class="nomrgn"><a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a></li>                
            </ul>
            <a href="https://www.futureplc.com"><img style="margin-top: 10px;" src="/Content/images/FutureFooterLogo-Transparent.png" alt="purch" /></a>
            <span>Copyright &copy; 2022. All rights reserved.</span>
        </div>
        <div class="clear"></div>
    </footer>

    <div class="rsp_ft">
        <div class="footer_resp">
            <ul class="tabs">
                <li class="click_btn"><a href="#">TOPICS</a></li>
                <li><a href="#">FOLLOW</a></li>
                <li class="right"><a href="#">ABOUT</a></li>
            </ul>
            <div class="clear"></div>
        </div>
        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="topic_box">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/storage">SSD/HDD</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>

                    <div class="topic_box">
                        <ul>
                            <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                            <li><a href="/tag/smartphones">Smartphones </a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
                            <li><a href="/tag/displays">Displays </a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>

                    <div class="topic_box no_mar">
                        <ul>
                            <li><a href="/tag/mac">Mac </a></li>
                            <li><a href="/tag/systems">Systems </a></li>
                            <li><a href="/tag/cloud-computing">Cloud </a></li>
                            <li><a href="/tag/tradeshows">Trade Shows </a></li>
                            <li><a href="/tag/guides">Guides</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
        </section>

        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow left"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="follow_block ctr">
                        <a href="http://www.facebook.com/AnandTech/"><img src="/Content/images/icon-facebook2.png" alt="" />Facebook</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="http://www.twitter.com/AnandTech"><img src="/Content/images/icon-twitter2.png" alt="" />Twitter</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="/rss/"><img src="/Content/images/icon-rss2.png" alt="" />RSS</a>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
        </section>

        <section class="panes">
            <div class="topic_sec">
                <div class="topic">
                    <span class="blk_arrow right"><img src="/Content/images/gryBg1.png" alt="" /></span>
                    <div class="follow_block ctr">
                        <a href="/home/about/">About</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/services/advertising/">Advertising</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="https://www.futureplc.com/terms-conditions/">Terms of Use</a>
                    </div>

                    <div class="follow_block ctr">
                        <a href="/account/fullsite?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Show Full Site</a>
                    </div>


                    <div class="clear"></div>
                    <div class="footer_copy">Copyright &copy; 2022. All rights reserved.</div>
                </div>
            </div>
        </section>


        <div class="mobi-footer">
            <div class="mobile"><a href="#">BENCH</a></div>
            <div class="topic_sec">
                <div class="bench_box show_resp2">
                    <div class="bench_carousel show_resp2">
                        <ul>
                            <li><a href="/Bench/CPU"><img src="/Content/images/bench_li_pic1.jpg" alt=""><span>CPU</span></a></li>
                            <li><a href="/Bench/SSD"><img src="/Content/images/bench_li_pic2.jpg" alt=""><span>SSD</span></a></li>
                            <li><a href="/Bench/GPU13"><img src="/Content/images/gpubench2013.jpg" alt=""><span>GPU<br>2013</span></a></li>
                            <li><a href="/Bench/GPU12"><img src="/Content/images/bench_li_pic3.jpg" alt=""><span>GPU<br>2012</span></a></li>
                            <li><a href="/Bench/Smartphone11"><img src="/Content/images/bench_li_pic5.jpg" alt=""><span>Smartphone<br>2011</span></a></li>
                            <li><a href="/Bench/Mobile"><img src="/Content/images/bench_li_pic6.jpg" alt=""><span>Mobile</span></a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                </div>
            </div>
            <div class="mobile"><a href="#">TOPICS</a></div>

            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="topic_box res_topicBox">
                        <ul>
                            <li><a href="/tag/cpus">CPUs</a></li>
                            <li><a href="/tag/mb">Motherboards</a></li>
                            <li><a href="/tag/storage">SSD/HDD</a></li>
                            <li><a href="/tag/gpus">GPUs</a></li>
                            <li><a href="/tag/mobile">Mobile</a></li>
                            <li><a href="/tag/enterprise">Enterprise & IT</a></li>
                            <li><a href="/tag/smartphones">Smartphones </a></li>
                            <li><a href="/tag/memory">Memory</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="topic_box no_mar res_topicBox">
                        <ul>
                            <li><a href="/tag/casecoolingpsus">Cases/Cooling/PSU(s) </a></li>
                            <li><a href="/tag/displays">Displays </a></li>
                            <li><a href="/tag/mac">Mac </a></li>
                            <li><a href="/tag/systems">Systems </a></li>
                            <li><a href="/tag/cloud-computing">Cloud </a></li>
                            <li><a href="/tag/tradeshows">Trade Shows </a></li>
                            <li><a href="/tag/guides">Guides</a></li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>

            <div class="mobile"><a href="#">FOLLOW</a></div>
            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="follow_block">
                        <a href="http://www.facebook.com/AnandTech/"><img src="/Content/images/icon-facebook2.png" alt="">Facebook</a>
                    </div>

                    <div class="follow_block">
                        <a href="http://www.twitter.com/AnandTech"><img src="/Content/images/icon-twitter2.png" alt="">Twitter</a>
                    </div>

                    <div class="follow_block width">
                        <a href="/rss/"><img src="/Content/images/icon-rss2.png" alt="">RSS</a>
                    </div>
                    <div class="clear"></div>
                </div>
            </div>
            <div class="mobile"><a href="#">ABOUT</a></div>
            <div class="topic_sec">
                <div class="topic res_topic">
                    <div class="topic_box no_mar">
                        <ul>
                            <li><a href="/home/about/">About</a></li>
                            <li><a href="https://www.futureplc.com/services/advertising/">Advertising</a></li>
                            <li><a href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a></li>           
                            <li><a href="https://www.futureplc.com/who-we-are/#contact">Contact Us</a></li>
                            <li><a href="/account/fullsite?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Show Full Site</a></li>
                            <li class="nomar">Copyright &copy; 2022. All rights reserved.</li>
                        </ul>
                        <div class="clear"></div>
                    </div>
                    <div class="clear"></div>
                </div>

            </div>

        </div>

    </div>

    <div class="login_popup">
        <div id="inlineLogin">
            <h2>Log in</h2>
            <h3><span id="ilMessage">Don't have an account? <a href="/Account/Register?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Sign up now</a></span></h3>
            <div class="login_left">
                <form action="#">
                    <div class="login_form">
                        <label>Username</label>
                        <input id="UserName" name="UserName" type="text" class="login_field">

                        <label>Password</label>
                        <input id="Password" name="Password" type="password" class="login_field">

                        <label class="fl-lt" style="margin-right: 10px;" for="RememberMe">Remember Me</label>
                        <input class="fl-lt" id="RememberMe" name="RememberMe" type="checkbox" value="true" /><input name="RememberMe" type="hidden" value="false" />
                        <input onclick="DoLogin(); return false;" name="" type="submit" class="login_btn" id="inlineLoginButton" value="LOG IN"><img alt="" src="/Content/images/ajax-loader.gif" id="ilAjaxLoader" />
                        <div class="clear"></div>
                    </div>
                </form>
                <div id="ilLost">
                    <a href="/Account/ResetPassword?r=%2fshow%2f17181%2fces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards">Lost your password?</a>
                </div>
                <div id="ilTerms">
                    We’ve updated our terms. By continuing to use the site and/or by logging into your account, you agree to the Site’s updated <a target="_blank" href="https://www.futureplc.com/terms-conditions/">Terms of Use</a> and <a target="_blank" href="https://www.futureplc.com/privacy-policy/">Privacy Policy</a>.
                </div>
            <div class="clear"></div>
        </div>
</div></div>
    <div id="oop_ad">
        <script type="text/javascript">
            tmntag.cmd.push(function () { tmntag.adTag('oop_ad', false); });
        </script>
    </div>
    <div id="1x1">
        <script type="text/javascript">
            tmntag.cmd.push(function () { tmntag.adTag('1x1', false); });
        </script>
    </div>
    <!-- Quantcast Tag -->
    <script type="text/javascript">
        var _qevents = _qevents || [];

        (function () {
            var elem = document.createElement('script');
            elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
            elem.async = true;
            elem.type = "text/javascript";
            var scpt = document.getElementsByTagName('script')[0];
            scpt.parentNode.insertBefore(elem, scpt);
        })();

        _qevents.push({
            qacct: "p-bduwCJZfRi0AI"
        });
    </script>

    <noscript>
        <div style="display: none;">
            <img src="//pixel.quantserve.com/pixel/p-bduwCJZfRi0AI.gif" border="0" height="1" width="1" alt="Quantcast" />
        </div>
    </noscript>
    <!-- End Quantcast tag -->
    <!-- Begin omniture Beacon -->
        <script id="omnitureProperties" language="JavaScript" type="text/javascript">
            

            var g_o = {};

            g_o.prop15 = "D=v15";
            g_o.eVar15 = "Non Member";
            g_o.prop35 = "";

            g_o.pageName = "anand:edt:17181:CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards:pg1";
            g_o.channel = "Editorial";
            g_o.prop2 = "D=v2";
            g_o.eVar2 = "Motherboards";
            g_o.prop4 = "D=v4";
            g_o.eVar4 = "News";
            g_o.prop5 = "D=v5";
            g_o.eVar5 = "CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards";
            g_o.prop6 = "D=v6";
            g_o.eVar6 = "anand-edt-17181";
                                        
            g_o.prop34 = "Motherboards|ASRock|Trade Shows|Alder Lake|LGA1700|CES 2022|B660|H670|Value Series|H610|H670M-ITX/ax|B660M-ITX/ac|B660M-HDVP/D5|B660M-HDV|H610M-ITX/ac|H610M-HVS|H610M-HDVP/D5|H610M-HDV/M.2|H610-HDV";
                

            //var s_code = s.t(); if (s_code) document.write(s_code);

        </script>
    <!-- End omniture Beacon -->
            <script type="text/javascript">
            var _gaq = _gaq || [];
            _gaq.push(['_setAccount', 'UA-1721979-1']);
            _gaq.push(['_trackPageview']);
            dataLayer.push({ 'OmnitureVars': g_o });

            (function () {
                var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
            })();
        </script>
    
        <script type="application/ld+json">
            {
                "@context": "http://schema.org",
                "@type": "NewsArticle",
                "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://www.anandtech.com/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards"
            },
            "headline": "CES 2022: ASRock Reveals its H670, B660, and H610 Value Series Motherboards",
            "image": {
                "@type": "ImageObject",
                "url": "https://images.anandtech.com/doci/17181/H670M-ITXax(L1)_678x452.jpg",
                "height": "452",
                "width": "678"
            },
            "url": "https://www.anandtech.com/show/17181/ces-2022-asrock-reveals-its-h670-b660-and-h610-value-series-motherboards",
            "author": {"@type": "Person","name": "Gavin Bonshor"},
            "publisher": {
                "@type": "Organization",            
                "@id" : "#AnandTechOrg",
                "name": "AnandTech",
                "url": "https://www.anandtech.com",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://www.anandtech.com/content/images/rss_logo.png",
                    "width": "400",
                    "height": "400"
                }
            },
            "ArticleSection": "Motherboards",
            "datePublished": "2022-01-05T22:15:00Z",
            "dateModified": "2022-01-05T22:15:00Z",
            "description": "At CES 2022, ASRock unveiled a total of nine Value Series models based on Intel&amp;#39;s latest 600 series chipsets, including one H670, three B660..."
            }
        </script>



<!--  .20 -->

</body>
</html>
