Some AMD users have been posting on social media, including Reddit, about experiencing intermittent connectivity problems when using USB ports on their 500-series motherboards. In response, AMD has reached out through a Reddit post that it has been made aware of the connectivity issues, and is requesting more information from specific users with the issue to help them resolve it. Since this announcement, many users have been reaching out to AMD.

AMD's X570 motherboards have been readily available since July 2019, and its B550 models have been available since June 2020 and have both become well established over the course of the last year and a half. The fact that users are now having USB issues begs the question whether the issues have been present all along but are now rising above the noise, or there is something related to the longevity of these systems.

AMD 500 Series Motherboard and USB Connectivity Issues?

The most common reproduction of this issue appears to be during the use of Virtual Reality headsets such as the Oculus Rift and HTC Vive, with an intermittent connection issue being more prevalent to these users. As USB is the main method to power and communicate with VR headsets and peripherals, any dropout, even slightly to the high-powered VR applications, would instantly be highlighted. That isn't the only problem it can cause, as streaming devices and USB audio interfaces could also experience power dropouts, which could be quite noticeable, especially if doing a recording.

While AMD hasn't pinpointed the exact cause of the issue yet, it asks its users to reach out to them over on Reddit by u/AMDOfficial, which is an official support channel for AMD. Extensively combing through user comments on Reddit, it doesn't seem to be solely related just to one section of hardware. Some of the issues that users report seem to stem from the release of PCIe 4.0 graphics cards on 500 series motherboards. Reddit user u/duddy32 also states that they have been having these issues with a B450 motherboard and a Ryzen 7 3700X processor, which precede the 500-series chipset. 


AMD's B550 Chipset layout, including USB connectivity.

One possible workaround touted to reduce (but importantly not completely stop) the issues is users changing the motherboards' settings from PCIe 4.0 to PCIe 3.0. Users on Reddit have been reporting although it has reduced the frequency of dropouts, it hasn't eliminated them, which could point to an issue between the USB hub controller and other parts of the chipset. Some users are also reporting the issue to be primarily on USB 2.0 ports, and some have had success by switching devices to USB 3.1 ports. It is also recommended to update the firmware to the latest AGESA version on models, which could reduce issues. Although at this point, it's possible to presume that none of the workarounds could fix these problems users are experiencing with random and intermittent USB cutouts.

Although AMD hasn't notified the reddit audience if it has been able to pinpoint the issue internally, it is asking users experiencing these issues to detail their hardware configurations and other relevant system information to allow AMD to recreate the issues on its end. AMD is also openly encouraging users to directly raise online service requests with AMD customer support to help correlate data and compare notes with other support claims to narrow down the problem potentially.


The rear panel of an X70 motherboard with USB 3.1, USB 3.0, and USB 2.0 ports.

It should be noted that not all users have experienced these issues - we've tested several dozen AMD AM4 motherboards and have used them extensively over the last 15 months, with exactly zero issues related to this. This is why this issue might only be being highlighted now - either users haven't noticed the issue, as a very slight cutout from a mouse or keyboard may not be very apparent, or they might be lucky that this issue doesn't affect them. However, enough users are coming forward with these intermittent USB connectivity issues to make the issue widespread across multiple models and processor combinations. This means the issue isn't specifically down to a certain manufacturer and looks more like an issue with AMD's chipset or how it connects from the USB hub to the chipset. 

If AMD does manage to pinpoint the issue with its in-house team and collaboration of consistent data points provided by its users, it's possible a future AGESA firmware update could alleviate the issues. Of course, if it is directly related to a design and hardware problem, which could be a much tougher nut to crack for AMD.

AMD's official statement posted on 02/20/21 can be found on Reddit herehttps://www.reddit.com/r/Amd/comments/lnmet0/an_update_on_usb_connectivity_with_500_series/

Related Reading

POST A COMMENT

36 Comments

View All Comments

  • CiccioB - Tuesday, February 23, 2021 - link

    The lack of "expected" data is not a problem on any (well designed) device.
    USB endpoints can stall as they need before sending the required data and the problem is only at the high level where maybe one would expect a sound or video streams that is however interrupted. To manage that there are different kinds of data transmission provided with USB like isochronous, bulk or interrupt.
    But at low level there must not be any disconnection issues due to this "lack od data" (and one may wonder why an SSD or VR device would not have data to send when they are working).
    Reply
  • kliend - Monday, February 22, 2021 - link

    I had 0 issues related to this, but my motherboard did eat an m.2 drive. Asus x570 tuf wifi Reply
  • BushLin - Monday, February 22, 2021 - link

    I once had USB dropout issues on my Pentium 4 system, the external HDD didn't perform consistently while I swung it around my head by the USB cable. Thought you all should hear about it. Reply
  • Targon - Monday, February 22, 2021 - link

    These issues may be related to there being a difference between USB ports that are supported directly by the CPU, and others that use another USB controller for additional ports. So, individual motherboards with various configurations may be the problem, taking PCIe lanes that are shared, vs. those which get the dedicated CPU PCIe lanes.

    The following link shows the differences, and how CPU based ports may not have a problem while chipset connected ports may have problems:

    https://www.quora.com/How-many-PCIE-lanes-does-Ryz...

    AMD may be aware that the issue is chipset related for example, but wants to verify by checking the motherboard topologies of those affected.
    Reply
  • CiccioB - Tuesday, February 23, 2021 - link

    It may be also that they know their chipset has a faulty USB/PCIe management and they cannot solve it by SW. These chipsets are almost one year old now considering the time they had simulated and tested them before going on mass market motherboards and still being in the process to ask for help to the unlucky users to understand what's wrong is not a good signal that they can do anything to fix it for real.

    They probably rushed to the PCI4 marketing band wagon too soon.
    Reply
  • Targon - Monday, February 22, 2021 - link

    I have an Asus ROG Crosshair VI Hero with Ryzen 3900X(upgraded from the 1800X I had started with), and have not had any of these issues. Obviously, PCIe 4.0 isn't supported on first generation Ryzen motherboards. Reply
  • Samus - Monday, February 22, 2021 - link

    No issues with any of the B550 systems I've built over the last 6-7 months. Time will tell I guess. Every board I've used was Asus, for what its worth. This could be a component (or batch of components) issue among one or many OEM's, who knows at this point. But what is interesting is no issues seem to be reported with retail systems, like those from Lenovo, HP, etc, indicating this could very well be a motherboard component issue, not a chipset\firmware issue. Reply
  • heickelrrx - Tuesday, February 23, 2021 - link

    an Embarrassing way to screw out, USB is old standard, and while AMD busy fixing their ancient 2.0 and slightly newer 3.1 Port, Their competitor already perfecting Thunderbolt, even contributing it's technology to USB Forum

    QA please QA QA QA
    Reply
  • Gigaplex - Tuesday, February 23, 2021 - link

    "The fact that users are now having USB issues begs the question whether the issues have been present all along but are now rising above the noise, or there is something related to the longevity of these systems."

    Pretty sure it's the former. My system has been doing weird things with USB devices since I got it, but it took a while to narrow it down to the motherboard/CPU.
    Reply
  • back2future - Tuesday, February 23, 2021 - link

    While having all kind of monitoring (temperatures, fan speeds, power supply) on new mainboards, there's almost none supporting USB related current (power) and voltages (because of qc >4.0 or USB-PD <=100W?) monitoring? Reply

Log in

Don't have an account? Sign up now