Total War: Three Kingdoms

Total War: Three Kingdoms - 3840x2160 - Ultra Quality

Total War: Three Kingdoms - 2560x1440 - Ultra Quality

Total War: Three Kingdoms - 1920x1080 - Ultra Quality

Strange Brigade The Division 2
POST A COMMENT

137 Comments

View All Comments

  • Gastec - Tuesday, July 09, 2019 - link

    Absolutely nothing at all. It's just ranting for the sake of ranting. A.k.a. trolling. Reply
  • psiboy - Monday, July 08, 2019 - link

    @Zingam Mate they've had good mid range mobile CPU's in laptops for a while now with a whole new Generation coming.. How is it AMD's fault your purchasing people don't do theor homework? You have 1 example to base your entire argument on. If a blind man touches an elephants trunk I fear he feels it is like a snake.. hardly the truth. Reply
  • Da W - Monday, July 08, 2019 - link

    i believe they have something, they are called PS 5 and XBOX 4 ! Reply
  • Gastec - Tuesday, July 09, 2019 - link

    We don't give a *censored by Google and the SJW woke armies* about your "mobile". Reply
  • WaltC - Sunday, July 07, 2019 - link

    Ryan--looks good--I'll be watching for the flesh-out later....;) I have a polite request--would you be so kind as to put the XT and 5700 together with a Ryzen 3k-series CPU on a x570 mobo and post some D3d12 multi-GPU benchmarks in SotTR? Reason I ask is because I currently have an RX-590/480 8GB X-fire system set up, and running the SotTR in-game bench in d3d12 multi-GPU mode I get ~62 fps @ 3840x2160, ~32fps running only the 590 (@ 1.6GHz), and I was curious as to how two 5700's in tandem might run this game. Also, I use lots of eye-candy--but not all--but it's better than medium settings, imo. I'd actually like to see more X-fire/d3d12 multiGPU results. I bought the RX-480 a couple of years ago, then added the 590 this past X-mas, on a whim, and have been surprised and pleased by how well it runs. Don't know why most sites won't cover multi-GPU anymore--AMD has made it almost idiot-proof these days--no more having to match operating frequencies of the cards, no more having to reboot to turn on/off X-fire in a game profile, etc. Thanks, if you can squeeze it in sometime...;) Reply
  • ballsystemlord - Sunday, July 07, 2019 - link

    Not that I intend to do mulit-GPU, but I always wondered why they stopped bench marking it. Reply
  • Ryan Smith - Sunday, July 07, 2019 - link

    Unfortunately our GPUs and CPUs are on opposite continents. So I don't have access to Ryzen 3000 at the moment, and Gavin doesn't have a Radeon 5700. Reply
  • WaltC - Sunday, July 07, 2019 - link

    Well, when you guys get some time..;) OK, I just finished six hours of driver hell with the 19.7.1's--I haven't seen this kind of behavior out of a GPU driver in > 15 years...! Make a long story short, the 19.7.1's I installed today threw a black screen up at the first initialization point during the Adrenalin's routine install--locked up the display at that point with constant signal to the monitor that kept the screen black. I got out of it, manually, but it was pretty severe--so when I got the desktop back I uninstalled the AMD GPU drivers in toto and thought I'd try it again from scratch, and after I'd made a restore point (Win10x63 18362.1000+)--which I didn't make the first time--woulda', shoulda' coulda', you know how it goes...;) I tried again thinking that maybe the problem was interference from some older driver files. Nah--locked at the first D3d initialization, again, same place, same black screen with same constant signal hard locked (monitor did not lose sync or go to standby for hours unless I powered it off.) It was horrible--it somehow hosed my boot bcd arrangement good--I couldn't even get to safe mode! Any way, it was like getting stuck in fly paper--the more I struggled the worse the mess got until tonight I was despairing of getting back in--nothing worked--! I could boot to my Rufus USB flash drive Win10 installations without a problem--but it was of little use since every time I tried to change my C:\ drive (L:\ when booting from RUFUS USB) the system rejected my attempts--even calling up Sys Restore manually from the X:\ Admin prompt did nothing--because of course it was booting from the wrong drive...;) Arrrgh! Finally I popped in my Macrum Reflect Rescue DVD and thought to have go ahead and simply restore my backup--and lo and behold I noticed a little blurb in the MR UI that said "Want your boot-drive problems fixed?" Yeah!--and selected for that and the MR fixed them at least well enough that I could get into safe mode again and then apply my Sys Restore file. So that was my Marathon in Hell on the day that I ordered my Ryzen 3K series CPU and my Aorus Master...I thought you'd like to know about this because you said you'd had a rough time with the drivers on the 5700's...I can second that loudly for my hardware! It's been many moons since I've seen a GPU driver this bad out of AMD--in fact, I can think of only one other similar incident since 2002, so this is definitely unusual for AMD. You know, my experience was so bad and weird that I could believe it if I heard that some disgruntled (or bribed!) employee at AMD decided to spread a little havoc and rain on AMD's parade today...OK, 'nuff said--I'm sticking with the 19.6.3's until I hear differently! Reply
  • psiboy - Monday, July 08, 2019 - link

    WaltC I don't install the "optional" drivers such as the 19.7.1 I onlyu install the "recomended" drivers as they have usually passed Microsofts WHQL testing. Thought that might help you not run into those sort of issues with "beta drivers" to quickly again mate. Pays to do your homework! Reply
  • WaltC - Monday, July 08, 2019 - link

    I don't disagree, and thanks for the comment--but you know, I always update when a new driver is released--and this is the first time in I don't know how many years that I've had this kind of problem! That's why I wrote it up--coupled with the problems Ryan and others have reported here even on the 5700/XT--although they didn't have the problems I did. I'm positive I won't be the only one seeing the problems here. I usually have lots of praise for AMD--but I can't do that when I see something like this. Looks like they might've pushed the card out a couple of months early, as I couldn't find them on Amazon US--or Newegg--which had so few in stock they didn't even have a category for the 5700s. Imagine--I was going to pick up an Anniversary card yesterday anyway but as of this morning can't find one at these outlets! Reply

Log in

Don't have an account? Sign up now