POST A COMMENT

75 Comments

Back to Article

  • ThisWasATriumph - Friday, February 20, 2015 - link

    Well I just checked mine for the first time since running the tool when it came out and it does look like performance has degraded on certain parts of the disk again...
    http://s13.postimg.org/pughd1kp3/hdtach.jpg
    Reply
  • Oxford Guy - Saturday, February 21, 2015 - link

    Funny how the tech site headlines last time read "Samsung releases firmware patch that fixes 840 EVO slowdown". They didn't say "claims to fix". Reply
  • MrSpadge - Saturday, February 21, 2015 - link

    Funny how you're complaining here at AT when their headline was just:
    "Samsung Releases Firmware Update to Fix the SSD 840 EVO Read Performance Bug"
    and write in the conclusion:
    "It's too early to say whether the update fixes long-term performance, but Samsung assured that the update does actually fix the NAND management algorithm and should thus be a permanent fix."
    Reply
  • Flunk - Saturday, February 21, 2015 - link

    Lack of reading comprehension is the easiest way to spot trolls. Reply
  • xype - Sunday, February 22, 2015 - link

    Dude, Android has _nothing_ on the iPhone!

    :P
    Reply
  • Oxford Guy - Sunday, February 22, 2015 - link

    Exactly, since Spadgie forgot to read and comprehend "last time". Reply
  • Oxford Guy - Sunday, February 22, 2015 - link

    No, what's funny (not really, actually) is your inability to read my post. Reply
  • alexrw - Sunday, February 22, 2015 - link

    Indeed. I just checked my 500GB 840 EVO and also took a hit: http://1.ii.gl/_1iFzMZWn.png Reply
  • biofishfreak - Friday, February 20, 2015 - link

    I've definitely noticed a drop in performance on my drive, and am glad they are still trying to resolve the issue.
    http://i.imgur.com/vv5Pbpj.png
    Please note, the above results are using Samsung's own Samsung Magician software. For reference, I applied the original performance fix software a week after it was released and currently have 4.64TB bytes written.
    Reply
  • colinw - Friday, February 20, 2015 - link

    Kicking myself daily for purchasing this drive. Reply
  • dgingeri - Friday, February 20, 2015 - link

    I replaced mine with an 850 Pro because of this issue, but I put the 840 EVO in an old laptop hoping it would still be good enough for that. Now I see it may not be. Reply
  • Alexvrb - Friday, February 20, 2015 - link

    Why? They sold a crapload and most of them are working fine. It's not a dreaded data corruption issue like a lot of entry-level SSDs have suffered, and it's correctable. I'd much rather have a hiccup like this that can be fixed without murdering your data, instead of a completely toast device like so many other budget SSDs.

    I've got an 840 Evo humming along nicely in one machine, and an 850 Evo in another. I only really go for Samsung and Crucial drives, myself, although I acknowledge that most of the Intel SSDs are very reliable too (if a bit costly).
    Reply
  • Samus - Friday, February 20, 2015 - link

    Fortunately I've only purchased 840 Pro's from Samsung which are amazing drives. All of my other drives are Intel 320, Intel 730 or crucial M550.

    What's funny though is even with the Evo 840 performance degradation, its still on par with an old X25-M or SSD 320...whats important to me is reliability first and foremost. I don't know if they are going to sacrifice data retention (long term data integrity) by shortening the read retry algorithms timeline. If they are... I would recommend you just deal with the peaks and valleys where there is slowdown until a tried and true fix is presented, because the drives are still very reliable IN FACTORY configuration before this, and future patches. But who knows, maybe it will just be over aggressive read retry algorithms after all... but I'm doubtful since they already tried to fix it by changing that.
    Reply
  • Alexvrb - Wednesday, February 25, 2015 - link

    I'd like to mention that in general I'm not a huge Samsung fanboy. I don't like their phones. I think many of their other consumer electronics are somewhat overrated. But I have had great luck with their SSDs. The Pros in particular ARE awesome, but for the money the Evo drives have always been hard to beat and nothing has really changed there. There's tons of problem-free systems out there with 840 Evos, and again since there's no data corruption I'm not stressing about it. I've seen one too many HDDs and badly-designed SSDs take a dump and eat all of your files to be freaked out by a repairable slow-down issue.

    Now if they had come out and said F you guys, buy our new 850 Evo, then I'd be outraged. But instead they continually work to make everyone happy, and their Magician software is both free and excellent (and they are dedicated to updating both the firmware with fixes as well as keeping Magician update).

    Anyway, I've had great luck with these older Evos and my newest 850 Evo is excellent. I picked up a 500GB unit so I finally feel like it isn't just a "boot drive" for me anymore. :D Now the only thing on my HDD is video!
    Reply
  • Notmyusualid - Saturday, February 21, 2015 - link

    Why? Because my two 840 Evos' performed SO bad, I had to break the RAID and use them individually.

    Or suffer much worse than a single-disk performance.
    Reply
  • TEAMSWITCHER - Sunday, February 22, 2015 - link

    "Well there's your problem." RAIDing together SSD's for more performance is a questionable practice. Reply
  • npz - Sunday, February 22, 2015 - link

    That is likely due to loosing TRIM in raid config. Reply
  • Alexvrb - Wednesday, February 25, 2015 - link

    Wow, that's silly. As the others have already said, any issues you're suffering are your own doing. Yikes man if one isn't fast enough RAID isn't going to help you! Just buy a single faster SSD instead of RAID, a Pro model for example, or even a high-end PCIe SSD if necessary. Reply
  • acsteitz - Thursday, August 27, 2015 - link

    I LOVE RAID 0. It does for data what Raid (insecticide) does for bugs, it kills it dead. (Old ad for Raid "Raid, it kills bugs dead.") In this day and age why anyone uses RAID 0 by itself is beyond me. If ANY drive in RAID 0 fails, you lose it ALL. Why would you double your chances of losing all your data for a not-noticeable-by-humans speed increase? Reply
  • Notmyusualid - Saturday, February 21, 2015 - link

    and me - x2 Reply
  • Mark_gb - Monday, February 23, 2015 - link

    I too have this drive. And I too am affected by the slowdown.
    HOWEVER, I have never lost a single bit of data, nor has the drive ever stopped working. To find out if the drive has actually slowed down, we have to run benchmarking programs to find out.
    So yeah, its slower than it should be. But, its still thousands of times fast than a hard drive, and it works perfectly well.
    We bought TLC SSD's. The very first TLC SSD's to go on the market in fact. We took a chance on it. And as we all know now, there have been some very minor problems. It was fixed once, and I expect that it will be fixed again.
    BTW, my 1TB 840 EVO is still the ONLY storage device in my system. And it keeps me happy! :)
    Reply
  • Hulk - Friday, February 20, 2015 - link

    I realize the EVO 840 uses 19nm TLC vs. the 40nm TLC for the EVO 850 and therefore the EVO 850 should be more robust in terms of these voltage fluctuations, but I'm wondering if we're going to see the same issues down the road with the 850 EVO's as well? It took a year or more for the issue to crop up on the EVO 840? I was looking to buy one and now I'm thinking the extra money (and peace of mind) for the MLC in the 850 Pro might be worth it. Reply
  • chucky2 - Friday, February 20, 2015 - link

    A tool that the user is going to have to run, or a cron job the tool itself will run (and thus needing the tool to be installed), is not an acceptable solution. They need to: 1.) actually fix the issue permanently, or 2.) exchange these drives for an equal or better performing drive that does not have the issue, or 3.) offer full refunds. Nothing less is acceptable IMO. Reply
  • Hulk - Friday, February 20, 2015 - link

    I agree.

    It's starting to look like the drive are degrading faster than expected or in a different manner than expected and they are scrambling to "band aid" the drives to get them out of the warranty period. If this goes on too long could they be looking at a class action?
    Reply
  • chucky2 - Friday, February 20, 2015 - link

    I'd add this to Samsung: OCZ took a beating on their SSD rep for a long time (it still exists)...don't go down that road in the community... Reply
  • mapesdhs - Wednesday, February 25, 2015 - link

    OTOH, if all those who spewed OCZ hate for so long don't react to Samsung in the same
    way if the problems persist, then that would be pretty weird. Haters should at least be
    consistent. :D

    Ian.

    PS. I have more than 40 OCZ SSDs, never had a problem with any of them. Have
    a bunch of Samsung models aswell, various others; the only one that went whacko
    was a SanDisk Extreme II which briefly stopped being recognised after a fw update
    attempt (eventually righted itself for reasons unknown, though btw, SanDisk were
    happy to send a replacement even though I made it clear I bought it used, so
    creds to them for that; they added it to their support setup too).

    Not bought an EVO so far, just seemed like the prices were too high IMO. Have
    many 830s, 840s, 840 Pro and 850 Pro though.

    Ian.
    Reply
  • nirolf - Monday, February 23, 2015 - link

    I agree too.

    I'd say the title is misleading, it seems that they're not working on a new firmware to fix the issue, they're just working on a work-around. That's really bad news and it probably says that the problem is kind of "unfix-able" (hardware level).
    Reply
  • nirolf - Monday, February 23, 2015 - link

    For the record, I have 2 of these (one 120 GB and one 240GB 840EVO) that both had the new firmware since day one and their performance is already sub-par (lots of ~100 MB/s zones) after 2 month of use. I trusted the "fix" and got screwed. I'll avoid Samsung for a long time for this. Reply
  • sheh - Friday, February 20, 2015 - link

    Would it be possible to get real information from Samsung on the data retention specs of this and other drives? Reply
  • sheh - Friday, February 20, 2015 - link

    I don't mean the JEDEC mandated specs, but more details. For example, stuff like retention-vs-P/E graphs. Reply
  • kgh00007 - Friday, February 20, 2015 - link

    My 120GB 840 EVO went back up to 350MB/s across the whole drive after applying the fix on the 15th of October last year.
    Now the speed has dropped to below 100MB/s (and even below 50MB/s in places) across 50% of the drive.

    I'm shopping for a new SSD for a new laptop and I can't bring myself to buy the 850 EVO because I don't trust it.

    I too would like to have this drive replaced with a drive that performs to the stated specification. My laptop now takes just as long to start up from shutdown with the 840 EVO as it did with the HDD.

    The media were all over these drives quoting the best speeds and awesome service times, but The reality is that these drives perform terribly in real life!!!
    Reply
  • ZeDestructor - Saturday, February 21, 2015 - link

    Get a Crucial MX100 or MX200 then. Somewhat slower than the 850 EVO, but reliable... Reply
  • kgh00007 - Saturday, February 21, 2015 - link

    Yeah cheers! I've had a Crucial M500 240GB for just as long as the 840 EVO. While it's a "slower" SSD, it's performance has remained constant the whole time and feels like the faster SSD! Reply
  • Pissedoffyouth - Monday, February 23, 2015 - link

    Yeah the m500msata is a lovely drive. Reply
  • Impulses - Saturday, February 21, 2015 - link

    Was there ever a fix for the original 840 non-EVO? Reply
  • Solid State Brain - Saturday, February 21, 2015 - link

    I've got two and I agree it would be nice to know if non-EVO 840 will ever be fixed. Reply
  • Jumangi - Saturday, February 21, 2015 - link

    They just need to bite the bullet and offer a recall/replacement for owners. Reply
  • FriendlyUser - Saturday, February 21, 2015 - link

    Hm, back to Plextor and Intel drives, I guess. Samsung is cheap, but not as reliable as I thought. Reply
  • Murloc - Saturday, February 21, 2015 - link

    I found out about this a few days ago and ran the test: my slowest speed is 0.7 MB/s.

    Yet I haven't noticed any slowdown, despite not having rewritten many of the files I read often.
    Reply
  • wavetrex - Saturday, February 21, 2015 - link

    I just run HDTach myself, noticed the big dips.. run the performance recovery, they are gone. I only have the SSD since last week and already these problems...
    Huh... wonder how long until I have to run the software again. Starting to regret the choice in buying it...
    Reply
  • donawalt - Saturday, February 21, 2015 - link

    My performance has degraded on certain parts of the disk too
    https://dl.dropboxusercontent.com/u/56053396/test1...
    Reply
  • 3DoubleD - Sunday, February 22, 2015 - link

    I have degredation on at least one of my drives at this point. (FYI, I'm running on SATA2) https://www.dropbox.com/s/1b2s533spbagatc/HDTune-2...

    I need to check the rest now...

    This is unacceptable. I have three 840 EVOs and at least two family members with one drive each. Following Anandtech's glowing review and in combination with the aggressive pricing of this drive, it seemed like the SSD to buy. But performance like what I'm seeing is completely unacceptable. Large parts of my drive are writing at ~50 MB/s. Samsung really needs to fix this, either by issuing a fix that will work or by replacing everyone's drives.
    Reply
  • 3DoubleD - Tuesday, February 24, 2015 - link

    I've tested my other 250GB drive in my laptop https://onedrive.live.com/redir?resid=5005B9DD0DF2... This one appears consistent, but strangely only hits ~300MB/s across the whole drive with HD Tune (running on SATA3). Running the Samsung test yields sequential read speeds of ~520MB/s, so that result in itself is a bit confusing. However, I can live with consistent 300MB/s access. My other drive dropping as low as 8.8 MB/s has completely unacceptable performance. Reply
  • Achaios - Saturday, February 21, 2015 - link

    My 840 Evo's 500 GB performance has NOT deteriorated since applying the fix back in January. I use it everyday as my OS and games drive.

    http://i.imgur.com/ApsTUOZ.jpg
    Reply
  • Solid State Brain - Saturday, February 21, 2015 - link

    That benchmark isn't going to show if your SSD is affected by performance deterioration on old data. You have to use something like HDTach or HDTune with a block size set to a rather high value (in the several megabytes range). These programs will test all the logical blocks of the drive sequentially, bypassing the file system, regardless if these blocks actually contain data or not. On correctly working SSDs, sequential read speed should be constant from the start to the end of the user addressable space, regardless of the data contained and their age. Reply
  • michal1980 - Saturday, February 21, 2015 - link

    so Samsung is now basically OC their SSD drives to get them out the door, then patching them later. When will a tech site call them out for this? Reply
  • Yongsta - Saturday, February 21, 2015 - link

    My drive: http://i.imgur.com/1Ubz1Ad.jpg

    Bought it about a year ago, in October I had speeds as low as 250 MB/s but after the patch it went back up to 350 MB/s - 400 MB/s range. It doesn't appear to be as bad some people but I still want it to be better. I have about 9.10 TB written according to Samsung Magician, I think there might be a bug with the program because all I do is browse the web on this drive and Windows is installed on here (I use a ram drive for browser cache) and my programs / games / movies are all stored on a separate SSD but for some reason my total bytes written sometimes goes up around 0.5 TB a day when I used the computer for only a few hours and browsed a few websites. Anyone else experience this bug?
    Reply
  • critter13 - Saturday, February 21, 2015 - link

    Has anyone been able to implement the fix on a mac? I simply cannot get it to work. Reply
  • Achaios - Saturday, February 21, 2015 - link

    Here's my HT TACH result:

    http://i.imgur.com/otQfe9o.jpg

    I ran it will playing World Of Warcraft. Lowest speed was 375 MB/Sec, and avg spd abt 430 MB/s. presumably, if I ran the test with no programs running I'd get even better results.

    My drive appears to be okay. I applied Samsung's fix on January 7, 2015. You can check my Samsung Magician's results on my previous comment.
    Reply
  • mercutio - Saturday, February 21, 2015 - link

    still having 840 non evo issues, tried contacting samsung who were no help.

    now days you can get cheap crucial m4 recertified on crucial's web site which are still faster than 840/840evo for read speeds.
    Reply
  • donawalt - Saturday, February 21, 2015 - link

    I went ahead and ran the performance restoration again and it made a huge difference.
    Before: degradation obvious at different spots:
    https://dl.dropboxusercontent.com/u/56053396/test1...
    After: performance consistently pegged at 512 MBps:
    https://dl.dropboxusercontent.com/u/56053396/test2...
    Reply
  • Achaios - Saturday, February 21, 2015 - link

    I ran HD TACH again, this time with no other software running in the background, and this time I got worse results:

    http://i.imgur.com/onAreoB.jpg

    It does seem like the perf of my 840 Evo has degraded slightly since January 7 2014 when I applied the last Samsung fix.
    Reply
  • aggiechase37 - Sunday, February 22, 2015 - link

    At this point, as far as I am concerned, if they don't replace these drives with something that doesn't doesn't break all the time, I will never buy another Samsung product again. Their phones have the worst reception in the business, their TV's are poor quality control (I had severe flashlighting issues on mine), their ssd's are clearly suspect, and being a heartbeat away from the one of the nuttiest countries in the world is not exactly reassuring. Samsung, replace these drives or you're dead to me. Reply
  • Achaios - Sunday, February 22, 2015 - link

    I am thinking the same too. Following this cluster you know what, I will never buy a Samsung SSD again and I will recommend the same to others. Updating my Overclock.net rig profile to include a note to that effect. Reply
  • EasterEEL - Sunday, February 22, 2015 - link

    I am using Samsung 830's myself but I have persuaded a couple of friends to by the 840 evo as they were very price sensitive. Check one at Christmas and it performance was definitely degraded so ran the tool to fix. Really disappointing to here the problem will come back. A company as big as Samsung should do the right thing as fobbing customers off with inadequate firmware fixes does nothing for credibility and customer loyalty. Samsung need to take a look at what Apple was eventually forced to do with the MacBook dry solder issue following a class action. Reply
  • Achaios - Sunday, February 22, 2015 - link

    I doubt that Samsung care. Unfortunately, by buying off cheap Samsung crap, we got "what we paid for" as the old saying goes, and that is cheap, inferior crap. Reply
  • Yongsta - Monday, February 23, 2015 - link

    No more Samsung TLC drives for me, I'm just gonna stick with Samsung PRO drives from now on, I never have any issue with those. Reply
  • Notmyusualid - Sunday, February 22, 2015 - link

    Indeed, price would usually play a part in it for me too - but as I was in South East Asia at the time of my purchases - I simply couldn't get my hands on the MLC Pro versions, so as only 840 TLC Evos were available, two of them it was for me.

    Meanwhile, my X25-E 64GB *still* chugs along without so much as a hiccup... I'm confident that I'll not fit anything less than an enterprise-class drive in a machine of MY OWN, again.

    But, not to pour scorn over Samsung alone here, I've seen a number of SSDs fail (one Intel MLC was DOA too), and I now do not keep any sensitive data on SSDs, it has all been moved to mechanical storage once again, and that is NOT due to the decreased cost / bit.

    Peace out...
    Reply
  • npz - Sunday, February 22, 2015 - link

    One thing that pisses me off about Samsung's firmware update system, both through Magician Windows software or DOS: it ONLY works on later generation Intel machines!! It's a long standing issue they acknowledge in their documentation but refuse to fix.

    That means if you're using the 840 EVO on an AMD system or older Intel (775 socket) you're screwed!
    Reply
  • Gigaplex - Monday, February 23, 2015 - link

    Worked fine on the AMD systems I tried it on, using the standard msahci driver. Reply
  • npz - Monday, February 23, 2015 - link

    What cpu and which chipset?

    It only works a very few select AMD chipsets.
    The DOS version does not work and will crash in fact. AM1/Kabini does not work (ahci nor ide) nor do older AM2/3 boards.
    Reply
  • iceblitzed - Sunday, February 22, 2015 - link

    Potential Temp fix:

    There is a program for windows called disk fresh.

    What it does is it does a rewrite of your whole drive.
    Reply
  • kgh00007 - Saturday, February 28, 2015 - link

    Yep, this works a treat! It restored my performance to around 350MB/s from below 50MB/s on parts of the drive. So worth using once in a while when performance drops until this problem is resolved. Reply
  • cerunnos - Sunday, February 22, 2015 - link

    They really need to fix this issues for models other than the EVO as well. This is my laptop after about a year of extremely light usage (a few times a month tops, mostly browsing and typing on the go). The performance drop is massive, programs like Chrome, Word, and even Windows now take noticeably longer to boot up. Bechmarks that read/write new data show 400+ reads.

    http://s13.postimg.org/wzfuctmpz/hdtach_samsung_fl...
    Reply
  • poohbear - Monday, February 23, 2015 - link

    well, atleast they're not dodging the question and trying to address the issue. I have 2 Samgung 840 Evos, part of buying the 2nd was Samsung's brandname and established reliability that came with that. So i hope they follow through on their reputation. Reply
  • OnBoard - Tuesday, February 24, 2015 - link

    I didn't learn.. I bought 840 EVO to fix my 840 vanilla as they said it's fixed now..
    840 (vanilla) http://imgur.com/dYJFuTt (you guys need to fix that still too)
    840 EVO new http://imgur.com/VUY3DkK
    840 EVO now 2months old http://imgur.com/WBUHUN2
    Reply
  • bg17aw - Saturday, February 28, 2015 - link

    Hey, what about the 840 drives??? I have one, and an Evo. I need both of them fixed! Reply
  • roadmalum - Sunday, March 15, 2015 - link

    Another temp fix: Run Spinrite on level 3 on your 840 EVO drive.

    Before: http://postimg.org/image/nh3i7o2xj/

    After: http://postimg.org/image/jd6upwp65/
    Reply
  • SputBob - Tuesday, March 31, 2015 - link

    We'll, March has come and gone... Reply
  • jellowiggler - Thursday, April 02, 2015 - link

    Where is that Magician with the fix in it? It's April 2 and the new version isn't here.
    I understand the there could be complex tecnhnical issues at play here. But this has been going on since late summer 2014. The first fix attempt was in the Fall. What gives?

    I will not be buying Samsung again. Crucial M series or Intel?
    Reply
  • JackNSally - Saturday, April 04, 2015 - link

    Any word on this update?
    http://tinypic.com/r/97pson/8
    Reply
  • jellowiggler - Tuesday, April 07, 2015 - link

    April 7 still no release....... I'm going to check once a week now just to see how long it takes them to fulfill their promise. Reply
  • dcaxax - Tuesday, April 14, 2015 - link

    The 840 (non-evo model) suffers from just as bad if not worse performance degradation (at least 50% slower) and now even my 830 is showing signs of slowing down by about 25%.

    Simply put I am never buying another Samsung drive again. From now on it's Intel or Crucial only.
    Reply
  • JerseyGeek - Tuesday, April 14, 2015 - link

    It's been months since the first 840 EVO problem announcement in October, and almost two months since the February announcement of the failed fix. Now, the 850 EVO is also having similar problems.

    Samsung SSDs used to be my top choice. I run several of them here, and have put numerous customers onto Samsung SSDs. After the horrible track record since October in dealing with their problems however, I’m now relegating Samsung into last choice as an SSD supplier.

    Their poor track record in fixing their SSD problems tarnishes their corporate name. It will take a long time (if ever) for them to regain my trust.
    Reply
  • acsteitz - Thursday, August 27, 2015 - link

    JerseyGeek, could you please provide a source for your claim that 850 EVOs are having the same problem? Based on your post I am scouring the web and cannot find anything anywhere that says that 850 EVO users are seeing degradation. (and I am posting 4 months after you) Reply

Log in

Don't have an account? Sign up now