Back in March I posted an update on my experiences with Crucial's RealSSD C300. In it I pointed out that not only had my review sample apparently bricked itself but I was also able to get the C300 into a state of extremely low performance (~20MB/s) that it could not get out of, even if I TRIMed the whole drive.

Crucial discovered the source of the problems and promised a fix in mid April. It's a bit later than that but we do finally have an update from Crucial. An updated fw has been posted to Crucial's site (Version 0002) and it promises the following fixes:

 Change Log:

 

  • Improved Power Consumption
  • Improved TRIM performance
  • Enabled the Drive Activity Pin (Pin 11)
  • Improved Robustness due to unexpected power loss
  • Improved data management to reduce maximum write latency
  • Improved Performance of SSD as it fills up with data
  • Improved Data Integrity

 

The update is destructive so you'll lose all of your data when you apply it. I haven't had the opportunity to test it thoroughly yet so if you're concerned, you may want to wait until others have used it. If you are a C300 owner, please feel free to leave your experiences with the update in the comments below.

Update: It seems as though the new firmware, designed to prevent drives from bricking, appears to be bricking drives. Hold off on this one guys.

I've also requested a 128GB C300 for review and I should see that in the coming days. I've got a ton of non-SSD stuff to deal with this week so I'm not sure I'll be able to get to all of it before I leave for Spain this weekend. If I can't get it done before I leave, I'll definitely tackle it all when I get back.

POST A COMMENT

21 Comments

View All Comments

  • nubie - Tuesday, May 04, 2010 - link

    In Crucial update, Drive TRIMS You!!

    Bummers, too bad for crucial, but I don't think it will be a huge problem for SSD uptake in general.
    Reply
  • gigahertz20 - Tuesday, May 04, 2010 - link

    It seems like these companies botch firmware quite frequently on SSD drives, I've never heard of so many problems with firmware updates before SSD drives came out. Even Intel managed to screw it up, they should really extend their testing time before releasing the updates to the general public. Reply
  • Axbattler - Tuesday, May 04, 2010 - link

    While on the subject of the C300, I do have a question on performance. Anandtech's benchmark place place the C300 at around half that of Intel's for 4k (unaligned) random write.

    Whereas a different test here (http://www.hexus.net/content/item.php?item=24173&a... shows the C300 ahead of Intel in that particular test.

    While I do not expect the result from two different sets of benchmark to be identical (or even nearly), I do not expect the relative position of the drives to be move unless they were very close to start with. Is it still possible there are no mistakes on either side?
    Reply
  • vol7ron - Tuesday, May 04, 2010 - link

    It's a good thing you'll be away when I'm out on travel.

    It's reassuring to know I won't be missing much.
    Reply
  • TheWhoDat - Wednesday, May 05, 2010 - link

    Anand,

    I was going to purchase the C300, since I have an Asus x58 MB that has SATA 3.0 6GB onboard.

    Seeing that you and others are having problems, what drive would you recommend now?

    I was hoping for a 200-256GB drive, to replace my 2x VelociRaptor RAID 0 setup, but everyone seems to love their Intel G2.

    Thank you for any recommendations.
    Reply
  • Lazlo Panaflex - Wednesday, May 05, 2010 - link

    The quality of Crucial products has certainly taken a turn for the worst. Don't see many enthusiasts running Crucial memory in their systems these days. For shame, Crucial. Reply
  • Golgatha - Wednesday, May 05, 2010 - link

    Thank you very much for posting this on the front page along with the timely correction. I just purchased this drive and it's my main boot disc now. I'd have been a bit mad to have a $680 brick to send back to Crucial if you hadn't posted the warnings in such a timely manner. Reply
  • Golgatha - Thursday, May 06, 2010 - link

    Looks like the firmware update has been pulled from Crucial's website for the C300 drives. Reply
  • assassin37 - Thursday, May 06, 2010 - link

    i updated to the 002 fw and my pc vantage score went up ,happy happy joy joy Reply
  • guffy - Thursday, May 06, 2010 - link

    Glad i checked here before using.

    Checked both the link above and browsing directly on Crucials website and in both cases the C300 firmware update is gone.

    Going to hold fire for now i think.

    thx
    Reply

Log in

Don't have an account? Sign up now